Support » Plugin: Klaviyo » Plugin Error

  • Resolved khalidmohammad

    (@khalidmohammad)


    Hi, I am using klaviyo plugin. And latest update came up with an error :

    Notice: Undefined index: klaviyo_popup in/var/www/html/iiepd.com/wp-content/plugins/klaviyo/klaviyo.phpon line 340

    Site using WordPress Version 5.2.4, Theme Astra and Elementor page builder.

    Thanks

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author klaviyo

    (@klaviyo)

    Hi @khalidmohammad

    Thanks so much for letting us know about this. I’m afraid we’re unable to re-create the issue with the details in your original post. If you could provide additional information so we can re-create the notice and further troubleshoot this we’d be happy to release a fix.

    Thanks!

    Hi,

    Please let me know which additional information you require. I will try to submit as soon as possible.

    Thanks

    Plugin Author klaviyo

    (@klaviyo)

    Hi @khalidmohammad

    I have listed some questions, would you please respond in an email to [redacted]

    Can you please confirm the version of the plugin you are using? Could you please provide the steps you took to transition from the old plugin (Klaviyo for Woocommerce v2) to this updated version? How are the settings configured for the Klaviyo plugin on your site (would you mind adding a screenshot in your email)? Did you have a Klaviyo form already installed? Are you trying to add a different/other Klaviyo form with the new plugin? Are you adding a Klaviyo: Email Sign Up or a Klaviyo: Legacy Email Sign Up form?

    We’ve installed and activated the theme and plugin you mentioned however these do not appear, by themselves, to reveal this Notice. Are you taking any specific actions to build a new page in Elementor or customizing the Astra theme that might be causing this Notice?

    We are able to locate the offending line of code but still cannot re-create this warning.

    Looking forward to your response!

    Plugin Author klaviyo

    (@klaviyo)

    Hi @khalidmohammad,

    Apologies, our Support Email was redacted. We’re just looking for specific steps to re-create this warning. Let us know if you have any further information we can use to try and re-create this issue.

    Thanks!

    Hi, I have the same issue,

    I installed the klaviyo plugin (latest version) on my storefront theme (woocommerce) I added the keys as said in the website but I didn’t add the snippet as when I tried it gave me an error as well.

    After doing that I can see the following error message on my checkout page

    Warning: Invalid argument supplied for foreach() inhome/customer/www/thesideoftheplanet.com/public_html/wp-includes/class-wp-list-util.php on line 150

    The error message disappear when the Klaviyo plugin is not active.

    Before I installed the plugin I created the Rest API key to integrate woocommerce and klaviyo. I don’t know if it’s related

    FYI This is the error message when trying to add the snippet:

    The code snippet you are trying to save produced a fatal error on line 3:

    Uncaught Error: Call to a member function get_title() on null in /home/customer/www/thesideoftheplanet.com/public_html/wp-content/plugins/code-snippets/php/admin-menus/class-edit-menu.php(213) : eval()’d code:3 Stack trace: #0 /home/customer/www/thesideoftheplanet.com/public_html/wp-content/plugins/code-snippets/php/admin-menus/class-edit-menu.php(213): eval() #1 /home/customer/www/thesideoftheplanet.com/public_html/wp-content/plugins/code-snippets/php/admin-menus/class-edit-menu.php(259): Code_Snippets_Edit_Menu->validate_code(Object(Code_Snippet)) #2 /home/customer/www/thesideoftheplanet.com/public_html/wp-content/plugins/code-snippets/php/admin-menus/class-edit-menu.php(122): Code_Snippets_Edit_Menu->save_posted_snippet() #3 /home/customer/www/thesideoftheplanet.com/public_html/wp-content/plugins/code-snippets/php/admin-menus/class-edit-menu.php(99): Code_Snippets_Edit_Menu->process_actions() #4 /home/customer/www/thesideoftheplanet.com/public_html/wp-includes/class-wp-hook.php(286): Code_Snippets_Edit_Men

    Plugin Author klaviyo

    (@klaviyo)

    Hi @emaillo,

    This is a separate issue from the OP’s message.

    Regarding your first message, this appears to be related to a lack of categories returned on a specific product when Klaviyo iterates through items in a cart. This can be handled to avoid throwing an error.

    In regard to your second message, can you please provide additional context around the snippet you are attempting to add? Klaviyo’s integration instructions should not include adding a snippet in order to successfully integrate Klaviyo with WordPress. Additionally, the error message is generated from a separate plugin, Code Snippets.

    Looking forward to your response.

    Issue is resolved now. We have some issue with our klaviyo plugin settings; we have added klaviyo details there and activated Enable Klaviyo signup forms. Which fix that error we had.

    Thanks, really appreciate your responses.

    Thank you very much for your quick response!!

    The error was fixed when I created categories for the store. But is there a way to avoid the error message without having categories in your store by any chance?

    That was my only problem actually, but I thought it was related to the snippet.

    For your records, I found the instructions about the snippet in this link https://www.klaviyo.com/wizard/web-tracking and I used the plugin Code Snippets to try to add it.

    Plugin Author klaviyo

    (@klaviyo)

    Hi @emaillo,

    Thank you for the follow-up, this is very helpful. We’ll make sure to avoid that error message in our next update to the plugin. We will also ensure that the ‘Setup Web Tracking’ instructions are up to date.

    Thanks again!

    Plugin Author klaviyo

    (@klaviyo)

    Hi @khalidmohammad,

    I’m glad this is resolved. If you wouldn’t mind sharing the specific details that were missing we’d be happy to update the plugin to better prompt users to provide that information in the plugin settings to avoid these warning messages in the future.

    Thanks!

    khalidmohammad

    (@khalidmohammad)

    Sure, We had installed klaviyo plugin, and added klaviyo email sign up widget via elementor for few pages. So when we removed it and and added again; public api key and Enable Klaviyo signup forms need to set again. Otherwise it will show this error :
    Notice: Undefined index: klaviyo_popup in/var/www/html/iiepd.com/wp-content/plugins/klaviyo/klaviyo.phpon line 340

    When its fixed, our all form fields were showing this error :
    Notice: Undefined index: button_styles in /var/www/html/iiepd.com/wp-content/plugins/klaviyo/inc/kla-widgets.php on line 24

    I fixed it by removing old widget and create new widget with same list id on every pages we used that klaviyo email sign up widget. Hope it will help.

    Regards

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Plugin Error’ is closed to new replies.