Support » Plugin: Klarna Checkout for WooCommerce » Klarna 400 Error and just spinning

  • Resolved tjs90

    (@tjs90)


    Ok so today i have had around 5K of orders fail due to errors which i just can’t figure out. I get a 400 error code in the logs and it says locale en_us which is wrong.

    I disabled the currency dropdown in woocom and i don’t have any other language files other than En_gb.

    I have taken 4 orders before this error started happening and i’m not sure if it due to the onboarding process by Klarna.

    If you could help asap it would be greatly appreciated.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • [ One hundred eightyseven eight hundred forty five characters deleted ]

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @tjs90 Please do not post large code or responses like that here, it doesn’t work after ~10 lines or so.

    If you need share that data please use https://gist.github.com/ or https://pastebin.com/ instead and post the link to that paste.

    Ok no problem, is anyone going to come and help with this?

    Hi,

    Can you give us more information from the logs on what that 400 error is?

    Have you been in contact with Klarnas merchant support too see if they can see more regarding that error?

    Best regards

    Andreas

    Hey thanks for getting back to me Andreas, here is the link to one of the logs i am getting.

    https://pastebin.com/NtJ2y48Z

    I have spoken to Klarna and they said everything is ok from their logs.

    If you go onto the website the iframe is there but if you go to place the order it says this payment it doesn’t work.

    I also had a message saying oops this isn’t available right now.

    If you want to go on to the website i can speak to you on live chat

    Hi,

    I see you also have a support case with us. I will look into the issue and then post the solution here when we have solved it.

    Andreas

    Hi guys i have fixed the issue the theme had some built in translation which was interfering with Klarnas API. I fixed it by removing all files for translation.

    Just a note klarna said that all their systems had trouble on Monday so this could be related.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.