Support » Plugin: Kirki Customizer Framework » Kirki loading Google fonts from old domain after migration

  • Resolved michaeljacoby

    (@michaeljacoby)


    Hi there,

    I’m hoping you can help me. I’m trying to migrate my site over to a new domain and everything is working well (using All in One WP Migration plugin). My only problem is that Kirki is still loading my google font choices from the old domain after the move. I’ve tried deactivating/activating Kirki, uninstalling/installing Kirki, deactivating and flushing all caches, and deleting all transients but nothing seems to work. I also reset all my font choices to san-serif and that fixes the problem, however, when I choose my google fonts again, it still defaults back to the old domain. The only thing that works is deactivating Kirki. When I do this, my new site retains my google font choices and loads them from the correct domain. However, if I activate Kirki everything defaults back to my old domain again.

    My site URL is the correct domain and everything else is linking to the new domain except the google fonts. Have you ever seen something like this before? Any help would be much appreciated.

    -Mike

Viewing 15 replies - 16 through 30 (of 44 total)
  • I’m using version 3.0.45 but it is not working either.
    This issue is not resolved.

    Same here.

    Hello im still waiting, you are saving old fonts and CANT BE REMOVED!!

    WHERE IS YOUR SUPPORT? HOW CAN YOU IGNORE ME SOO MUCH TIME?

    I have still the same problem. Support would be really appreciated.

    Thread Starter michaeljacoby

    (@michaeljacoby)

    Here is what worked for me. Try uninstalling Kirki. Then clear all cache and transients. Then reinstalled Kirki. Also, if you have any cache running on your server like pagespeed make sure you clear that too.

    I tried everything to fix this issue. I cleared the cache, reinstalled Kirki, removed every reference to the old domain from the database an the wp-contet folder but it is still not working.
    Everytime I reinstall Kirki it will fetch the old domain again.
    I searched my whole webspace for references to the old domain and removed them. I have no idea where Kirki is getting this domain from.
    Kirki is trying to load fonts from the old url inside the kirki-inline css file.

    How is this possible? Does anyone have an idea?

    @fguespe Did you found a solution for your problem?

    NO!

    actually i tried everything like you, and still no results.

    I still will try to do all this locally and actually found where is this value store, since is not getting it from transients, somewhere it must be!

    Very bad way of storing data this plugin

    Plugin Author Ari Stathopoulos

    (@aristath)

    > I still will try to do all this locally and actually found where is this value store, since is not getting it from transients, somewhere it must be!

    It is in a transient.
    You can see that it is stored here: https://github.com/aristath/kirki/blob/v3.0.45/modules/webfonts/class-kirki-modules-webfonts-embed.php#L206-L207

    The transient name is built here: https://github.com/aristath/kirki/blob/v3.0.45/modules/webfonts/class-kirki-modules-webfonts-embed.php#L148

    That is how the plugin stores its data.

    And you can even reset the plugin transients by appending &kirki-reset-cache in your URL, the code for that part can be seen here: https://github.com/aristath/kirki/blob/v3.0.45/modules/webfonts/class-kirki-modules-webfonts-embed.php#L157-L159

    Are you sure you are using the latest version of the plugin? 4 months ago we shortened the transient cache time to a day (I believe it was a week before that).

    > Very bad way of storing data this plugin

    Please refrain from such statements. The fact that you don’t understand something doesn’t mean that it’s bad. All it means is that you don’t understand it.

    Excuse sir,

    There are 2 threads that tells you that your fix ISNT WORKING
    And you are still repeating that we check the version of the plugin or that we use this useless link {site-url}/?action=kirki-reset-cache

    Already told you many times this fixes DO NOT WORK

    https://wordpress.org/support/topic/kirki-loading-google-fonts-from-old-domain-after-migration/

    Plugin Author Ari Stathopoulos

    (@aristath)

    I apologize if my previous reply seemed a bit aggressive. I understand that you have an issue on your sites and I can understand you’re frustrated.
    However, accusing someone’s work – no matter if it’s justified or not – can stir up feelings of annoyance and I got defensive.
    My apologies.

    Did you try deleting the font-files from your server? If you login via FTP and delete them they should be re-downloaded and if there’s some remnant of the old URLs it should be deleted automatically.

    YESSSS, you solved!! the trick was to DELETE the fonts and then do de {site-url}/?action=kirki-reset-cache

    And now it workss! Finally!

    Apologize for offending you,its funny actually, i love kirki , and i built my custom theme with over 200 theme options(ecommerce oriented) and its one of the most important tools i use for running our business. Keep the good work!

    SOLVED IT!

    The trick was to DELETE the fonts via FTP and then do de {site-url}/?action=kirki-reset-cache a couple of times 🙂 Also delete all caches from plugin and server.

    Finally!

    Plugin Author Ari Stathopoulos

    (@aristath)

    That’s great news. Finally! 🙂

    I’m currently refactoring these things for v4.0.
    I’ll keep investigating to see what it was that could have caused it in the first place.
    One thing is for sure though: The caches won’t be an issue after version 4.0 gets released since these parts are soon to be completely rewritten and refined. I’m taking the plugin line-by-line and optimizing some things so I’ll get to the the bottom of this 😀

    Oh yes, I also got it working! Deleting the fonts and clearing the plugin cache solved the problem.
    Thank you @aristath for your support!

Viewing 15 replies - 16 through 30 (of 44 total)
  • You must be logged in to reply to this topic.