Support » Theme: evolve » “Kirki” Error website broke

  • Resolved mnlibrarygrrl

    (@mnlibrarygrrl)


    Our tech guy just updated from .4 to .9 and our website started throwing this error:

    Fatal error: Class ‘Kirki’ not found in /home/alplonli/public_html/wp-content/themes/evolve/inc/admin/customizer/customizer.php on line 1217

    We went back to older version…..Any thoughts??

    Thanks!!!

Viewing 15 replies - 16 through 30 (of 36 total)
  • @romik84 tested and fixed! Thanks so much for the solution, website is back up and running.

    Seems to do the trick for me also 🙂

    @scottyskungfu , @helihautala thanks, appreciate it!

    Eva

    (@localport)

    @romik84, I had the same issue in a WPMU installation, solved with your code in customizer.php
    Thank you

    @localport New update 3.9.8. resolves everything

    Hi Romik,

    I hereby confirm your change in line 1142:

    if ( is_customize_preview() ) {
    evolve_call_customize_register();
    }

    This has worked for me on two sites.

    Thanks!

    thanks everyone 😉

    I have lost both front and backend access getting HTTP ERROR 500. Someone suggested to rename evolve theme into something else within cPanel so wp switch to default theme. However I do not have any other theme installed within my wordpress installation (I have deleted all except Evolve) and I don’t know how to make a fix ?

    Any solution appreciated. Just please try to make it’s description noob friendly as much as possible as my skills are close to complete beginner 🙁

    UPDATE:
    After triple reading of the replies I have figured out what to change and where and looks like error is gone being able to log in. Thanks everyone for instructions !

    P.S. Hopefully future updates won’t break the theme again.

    • This reply was modified 1 year, 2 months ago by justaniceguy.

    Fix worked like a charm -thanks @romik84 for providing it.

    bskno

    (@frankmartialarts)

    Around 1 hour ago I opened my WP admin page by my pc (win.7), and I got the error, but after 10 min I tried the same page with my tab (win.10) and no error whatsoever!
    Then I updated the theme to 3.9.8, everything is fine and stable!

    Thanks for your effort and great service @romik84! Good job.

    • This reply was modified 1 year, 2 months ago by bskno.

    @frankmartialarts thanks 😉

    Confirmed that fix worked for me as well! 🙂

    @tgatrost thanks!

    Hi Everybody,

    Need help urgently, my website is down, i’m getting this :

    Fatal error: Uncaught Error: Class ‘Kirki’ not found in /home2/ab68042/public_html/wp-content/themes/evolve/inc/admin/customizer/customizer.php:1217 Stack trace: #0 /home2/ab68042/public_html/wp-content/themes/evolve/inc/admin/customizer/customizer.php(1142): evolve_call_customize_register() #1 /home2/ab68042/public_html/wp-includes/class-wp-hook.php(286): evolve_load_the_theme_options(”) #2 /home2/ab68042/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #3 /home2/ab68042/public_html/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 /home2/ab68042/public_html/wp-settings.php(450): do_action(‘init’) #5 /home2/ab68042/public_html/wp-config.php(85): require_once(‘/home2/ab68042/…’) #6 /home2/ab68042/public_html/wp-load.php(37): require_once(‘/home2/ab68042/…’) #7 /home2/ab68042/public_html/wp-blog-header.php(13): require_once(‘/home2/ab68042/…’) #8 /home2/ab68042/public_html/index.php(17): require(‘/home2/ab68042/…’) #9 {main} thrown in /home2/ab68042/public_html/wp-content/themes/evolve/inc/admin/customizer/customizer.php on line 1217

    I can’t access my wordpress admin panel (same fatal error occurs).

    What shoul I do to fix it?

    Thank you in advance for your help!

    William

    @williamgularte Please read this thread for the fix.

Viewing 15 replies - 16 through 30 (of 36 total)
  • The topic ‘“Kirki” Error website broke’ is closed to new replies.