Support » Plugin: Manage Notification E-mails » Kills another plug-in

  • I am using the latest versions of everything, including your plugin. I’m using OptimizePress and its related plugin, OptimizeMember. Within OptimizeMember, I can change the text of the email sent to new users. That is to say I could before i updated your plugin. Now, I see this error message from OptimizeMember:
    “Conflict warning: You have another theme or plugin installed that is preventing OptimizeMember from controlling this aspect of your installation. When the pluggable function wp_new_user_notification() is handled by another plugin, it’s not possible for OptimizeMember to allow customization of New User Emails…if you DO want to use OptimizeMember’s customization of New User Emails, you will need to deactivate one plugin at a time until this conflict warning goes away.”

Viewing 1 replies (of 1 total)
  • Plugin Author Virgial

    (@virgial)

    Hi, thanx for giving your feedback. I’m sorry to inform you that there is no simple solution for your issue. The pluggable function wp_new_user_notification is a core function in WP and you can only overwrite it once. So if an other plugin overwrites this function, than you have to disable the notifications plugin.
    The other solution is to hack into the notifications plugin and remove the issued pluggable part.
    open the file in the plugins folder manage-notification-emails/includes/pluggable-functions.php and remove the stuff between:
    if (!function_exists(‘wp_new_user_notification’) ) : …. endif;
    Be aware that after a new update of the notification plugin you’ll have to redo this fix.

    Hope it helps

Viewing 1 replies (of 1 total)
  • The topic ‘Kills another plug-in’ is closed to new replies.