Support » Plugin: NextGEN Gallery Optimizer » Killing the dash!

  • Resolved wilko007

    (@wilko007)


    Hi,

    I think I posted to the wrong thread before!

    Anyway, NextGEN Gallery works fine on my local server, but once i upload the site I have to disable the plugin (manually by renaming the NextGEN plugin directory via FTP) to get the dashboard to respond properly. I could open the dash, use the menus (except the plugins menu) but not open media library or edit a page while the plugin was active.

    Does anyone know why this might be happening please?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi @wilko007,

    I believe NextGEN v2.x.xx still persists hard-coded URLs to files in the database, and this may be responsible for the trouble you’re experiencing when moving the site to a production server (as you’re now likely using a different hostname/domain).

    I’d recommend opening your database’s SQL file in a text editor, and use its find tool to search for any instances of your local server’s hostname (e.g. “localhost”, “127.0.0.1”, “wilko.dev” etc.). If you find any, you’ll also be able to see their location in the database, and then you can use a tool such as phpMyAdmin to update them.

    Also, you should let the developers know about this issue, so it can be resolved in a future release…

    https://wordpress.org/support/plugin/nextgen-gallery

    I hope this helps!

    Cheers,
    Mark.

    • This reply was modified 5 years, 8 months ago by Mark Jeldi.
    Thread Starter wilko007

    (@wilko007)

    Thankyou very very much for that Mark!

    It did indeed sort the conflict out and now I can edit posts and pages and the Dashboard responds as it should….except the Gallery > Other Settings page which for some reason is set to visibility:hidden.

    Any ideas why that might be and how to fix this?

    Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi @wilko007,

    You’re very welcome, and it’s great to hear that helped you out 🙂

    I’m not sure why the styling for that admin page would be set to “visibility: hidden”, but you might like to load it up again with your browser’s developer tools open, and have a look at the Elements/Styles section — to shed some light on exactly where (and in what file) that’s being set. From there you can take appropriate action (e.g. deactivate a conflicting plugin/update custom code etc.)

    Also, while you’re there, you might want to check for any JavaScript errors in the console.

    Another possibility might be that you need to empty NextGEN’s cache at Gallery -> Other Options -> Miscellaneous, which may fix the problem permanently. However, you’d need to edit out the “visibility: hidden” CSS in your browser’s dev tools first, so you can load the page.

    I hope this helps!

    Cheers,
    Mark.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Killing the dash!’ is closed to new replies.