Support » Plugin: iThemes Security (formerly Better WP Security) » kicked out of wordpress dashboard and login redirects to homepage

  • Hello, Last night I was editing a draft. After trying to save, I got kicked out of my dashboard. The page said “this page does not exist”.

    I tried to log back in, and I was redirected to my website’s homepage instead.

    I disabled all plugins. When I activated ithemes security, the same issue happened.

    I activated all other plugins, and I am able to log in.

    If it provides any insight, another plugin amp gives me the same issue. I tried activating amp and iThemes Security separately, with the other disabled, and I get the same issue with both.

    I have been using both for several weeks now without issues. amp just had an update, and I reached out to their support forum as well.

    Thanks for your help!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • MATT M

    (@beardedginger)

    Hi,

    You can temporarily disable the Security Plugins features by adding the code below to your wp-config.php file above the “That’s all, stop editing! Happy blogging.” comment. Note you’ll need to remove it to re-enable the features of Security Pro.

    define(‘ITSEC_DISABLE_MODULES’, true);

    Once you are back in can you please go to Security> Settings> Away Mode and make sure that the module has not been turned on?

    Thanks!

    Matt

    Hi thanks for your help and response! Today I was able to activate both plugins without being kicked out. Thanks!

    Hi

    I had the exact same issue only 4 days ago, and that line of code didn’t work. I removed all plugins, reinstalled wordpress and put wp-content back without any plugins being activated, and still could not get into the backend of my site.

    This has been a major issue getting back in, keeps redirecting to the home page.

    Once you put that code into the wp-config and it still doesn’t work then you can’t follow the other step getting into the backend.

    This is the only client I have used your plugin in, and looking at the way it was redirecting me to the home page, it was like it doesn’t recognise me as a ADMIN …

    So I thought it was possibly this plugin and removed it completely and along with most other files, and restored another version of the database.

    Still no luck.

    So what is the issue that this plugin, causes changes possibly in the wp-includes folder somewhere by the looks of it ?

    Please advise.

    Regards
    Kristin

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.