Support » Plugin: Yoast SEO » "keyword doesn't appear in the first paragraph"

Viewing 11 replies - 1 through 11 (of 11 total)
  • I too have just noticed this issue.

    This is occurring upon edit AFTER publication or scheduling. Creating a brand new post works just fine.

    Subsequent edits will blow away the greenlight. See the following examples:

    You have not used your keyword / keyphrase in any subheading (such as an H2) in your copy.
    The keyword doesn’t appear in the first paragraph of the copy, make sure the topic is clear immediately.

    The above redlights did not exist until AFTER edit of a scheduled post. The same thing occurs with published posts.

    I have to face problem while using SEO YOAST plugins. My problem is that i have to use keyword which is staid in my url + first header + first paragraph but still my page is POOR and get ERROR like “The keyword doesn’t appear in the first paragraph of the copy, make sure the topic is clear immediately.”

    Please Help as soon as possibly

    I’m getting this issue too – and it doesn’t seem to matter whether I’m editing a scheduled/saved post or writing a new one. It’s completely random but definitely becoming a more frequent issue.

    I’ve searched high and low for a fix but can’t find one. Some people on this forum have previously suggested an issue an older PHP script (I think 3.4 from memory). We’re using the latest PHP script though.

    I’m pretty certain it’s a bug and I wish someone would fix it. By their nature our posts aren’t very long and the issue is causing most of our posts to go to an amber light instead of a green one.

    Help, I am getting this now and it was fixed last time round before this update….

    thanks

    Colin

    I think I’ve found a potential explanation for the issues we’re facing.

    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-the-keyword-doesnt-appear-in-the-first-paragraph-of-the-copy/page/2

    This post implies the issue arises if you use anything besides a simple <p> to format your text following <h1>.

    In our case, we’re using <p style=”text-align: justify;”>. Wrapping the text ( <p><p style=”text-align: justify;”> text </p></p>) doesn’t do any good. However, disposing of <p style=”text-align: justify;”> text </p> entirely and replacing it with a simple <P> text </P> clears up the issue.

    Unfortunately this isn’t an option for us because of our theme and style guidelines, but it might help someone.

    Still, very annoying that this appears to be a longstanding bug that’s not yet been fixed.

    Same happened for me.

    But, after changed <p style=”text-align: justify;”>First paragraph</p> to <p>First paragraph</p>, result is fine.

    ScottFromPA

    (@scottfrompa)

    I have the same issue. I’ve been on many forums and therre are MANY who are wondering what the solution is. I can’t find one.

    I have the same issue, and have had for ages (many versions).

    I hadn’t noticed, until reading warezmoney post above, that if I have no paragraph formatting, and have just a plain <p>text</p> it works fine. Otherwise it says the keyword is not in the first line.

    Surely this is a fixable bug??

    Fixed! I faced the same problem and fixed it. This is not really not a problem with Yoast plugin. When you copy texts or article from any source or sometimes from some word processing software like Microsoft Word, there is some Markup added in the text/article. Yoast considers these markup as first paragraph so problem occurs. To fix this problem click on “text” tab in WordPress editor and remove all codes before your first line of the article.

    I came across this issue but was able to solve it.

    My Focus Keyword: nice dog blog

    First paragraph before (not working):
    There are many nice dog blogs on the Internet.

    First paragraph after (working):
    There are many a nice dog blog on the Internet.

    Please read on for the explanation.

    My focus keyword was nice dog blog (singular). I occasionally used the singular form of this as well as the plural, nice dog blogs. I thought that to be on the safe side, I would make the focus keyword the singular form. I knew for a fact that the focus keyword appears in the first paragraph of the copy (plural form), but this Yoast plugin kept giving me the red light along with the message, “The keyword doesn’t appear in the first paragraph of the copy, make sure the topic is clear immediately.

    I tried everything to make it work. My first paragraph was already between paragraph tags. In the end, the problem ended up being that I was adding an “s” to my focus keyword within my first paragraph (i.e. nice dog blogs), and despite the fact that my focus keyword was contained within this, this was the issue that was giving me the red light! To solve this problem, I simply removed the “s” from my focus keyword within my first paragraph.

    This Yoast plugin seems to look for the focus keyword separating words by spaces rather than searching the entire content for the exact focus keyword match.

    Hope this helps someone and saves them from some frustration! If you have done what I’ve described and are still not able to get it working, feel free to contact me for help.

    Hisham

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘"keyword doesn't appear in the first paragraph"’ is closed to new replies.