Support » Plugin: Klaviyo » key not saving under settings

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author klaviyo

    (@klaviyo)

    Hi @abossola

    That field takes the Public API key associated with your Klaviyo account. It is only 6 characters long. If you’re attempting to add your Private Key (prefixed with “pk_”) it will not save as expected and you’ll continue to receive that notice.

    Best,
    Klaviyo

    Thread Starter abossola

    (@abossola)

    excellent! resolved…

    I just tried to remove the prefix_ and it still wont save. it just reloads blank. anything else I can do?

    Plugin Author klaviyo

    (@klaviyo)

    Hi @jvas1704

    If there is a “pk_” prefix then this is a Private API key. This is the incorrect key to use in your Klaviyo plugin settings. Use the Public API Key which is 6 characters and can be found following the instructions provided in the link in the Klaviyo Settings form.

    Best,
    Klaviyo

    That did it! Thanks!

    baamodt

    (@baamodt)

    So I am having this same issue, but I am using the correct key, but it just keeps showing up as blank?

    Can you assist here?

    Thanks!
    Brooke

    Plugin Author klaviyo

    (@klaviyo)

    Hi @baamodt if you’re using the 6 character key inside your Klaviyo account found here: https://www.klaviyo.com/account#api-keys-tab in bold at the top for the Public API field and it is not working still, do you see any errors? If not, would you mind writing into our support (https://help.klaviyo.com/hc/en-us/articles/115001002272-How-to-Contact-Support) with a video / screenshots of you trying to save this so we can take a deeper look there?

    Best,
    Klaviyo

    baamodt

    (@baamodt)

    When I go to type the customer key/secret key into Klaviyo for the last step… it says “The Klaviyo extension is uninstalled or unavailable.”

    I have reached out to live chat already about it and they said they can not help with this!

    Any help is appreciated.

    Thanks!
    Brooke

    Plugin Author klaviyo

    (@klaviyo)

    @baamodt we should be able to help out with email support here, could you follow the steps listed in the help center guide to contact email and I will make sure we get you a response! Could you please have a subject as:

    WooCommerce Integration Questions (WP Forum baamodt)

    That way I can look it up in our system and make sure it get’s routed to the correct team! Sorry for the inconvenience and look forward to getting this resolved!

    Best,
    Klaviyo

    baamodt

    (@baamodt)

    Just emailed someone about it!

    Hope someone reached out soon.

    Thanks,
    Brooke

    Hi, I am also having
    “The Klaviyo extension is uninstalled or unavailable.” show up in the Klaviyo settings when I attempt to connect Woocommerce.

    I have installed the WordPress plugin and I think I have followed the correct steps.

    Hopefully, there is a solution.

    Thanks!

    Plugin Author klaviyo

    (@klaviyo)

    Hi @beebop666

    As noted in previous responses for this thread, please ensure you are using the 6 character Public API key. Please see above responses on how to do so.

    If you’ve successfully saved the Public API key in the plugin settings and you still continue to encounter this issue then please reach out to our Support Team.

    Best,
    Klaviyo

    Hi @klaviyo,

    I have indeed done that. I’ll contact support! Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘key not saving under settings’ is closed to new replies.