Support » Plugin: Publish To Apple News » Kevin – Continued Discussion

  • Resolved RANSOM COLLECTIVE

    (@ransomcollective)


    Hello Kevin, This wasn’t working for me and I had to take a break for a while. I’m back, hoping the Apple News platform has matured, but I am still having a couple of issues. Although, the experience is better now!

    WordPress Version: 4.9.8
    Wordpress Apple News Plugin Version: 1.4.3
    MacOS Mojave Version: 10.14
    Safari Version: 12.0 (14606.1.36.1.9)
    iOS Version: 12.0

    Here is our Channel
    https://apple.news/TPBJUAUewQhKlhtPD10BQSA

    1) First, the big one. Since we have last corresponded, I have published 800+ articles old and new. When I login to News Publisher on iCloud, I see over 100 articles in the Sports section for example. In the same Sports section, on the iPhone X News App and MacBook Pro Mojave News App, I see only 9 articles no matter how many times I pull to refresh. These devices are on the latest iOS and macOS. However, on an iPad Pro (with a different Apple ID) I see the correct number. I have force quit the apps, restarted the devices and I am an Apple Certified Technical Coordinator so all of my devices are on the latest OS. There are also 3 Drafts on News iOS app and on Apple News Publisher there are 0. There has to be a caching issue. This same issue happened months ago when we had our previous discussion. The sections are set up properly.
    See screenshots
    https://www.dropbox.com/s/j9w19i5y24mro93/Screen%20Shot%202018-09-30%20at%205.25.38%20PM.png?dl=0

    https://www.dropbox.com/s/eslmizqep91ohg1/Screen%20Shot%202018-09-30%20at%204.36.24%20PM.png?dl=0

    Note: both of these Apple ID’s are “Members” of this News Publisher account.

    1a) This is a comment from the Apple Dev forums that mirrors my experience. I have not attempted to delete the app and reinstall app yet. I wanted to get your feedback first.

    * “I have been having the same problem, and the number of stories is different for me than my colleagues. The only thing that appears to fix it for me is to delete the app and reinstall it. Then the back stories that I’ve published to the Apple News app show up. Simply refreshing the app doesn’t work for me which is unfortunate because there’s no way of knowing what stories people will see on our channel since there is no consistency. There definitely seems to be a major caching issue with the app.”

    2) If you look in the Sports Section, there are a couple of articles that are out of chronological date order. These articles have NOT been “Promoted” in News Publisher so it appears as though the plugin is not sending the date correctly to Apple’s servers OR News Publisher is not respecting the polish date. Keep in mind, I have just “Published” hundreds of old articles via your plugin and it appears as though, almost all, are listed correctly by date of publish on our website. Any thoughts on why this isn’t perfect?
    See screenshot
    https://www.dropbox.com/s/recygto1ctylxxt/IMG_8119.PNG?dl=0

    3) As described in the second section below, the “Done” button in your plugin is non-functional. Even after logging out of WordPress, restarting the browser, and restarting the computer it does not do anything.

    4) These are relating to using the Filter action in your plugin:

    4a) The filter does not seem to work. As you can see in the screenshot, the dates are selected and the filter button has been pressed, still I am getting September dates in 2018 when I have selected and filtered from January 2017 – April 2017.
    See screenshot
    https://www.dropbox.com/s/tjxmhsbf52cboa6/Screen%20Shot%202018-10-01%20at%203.39.05%20PM.png?dl=0

    4b) I cannot publish the article in the screenshot. Status is (NOT_FOUND keyPath articleId). When I attempt to republish I get the error “skipped… because already in sync”
    See screenshot
    https://www.dropbox.com/s/lxjk96hkhh81iig/Screen%20Shot%202018-10-01%20at%203.39.50%20PM.png?dl=0

    4c) Under the “Show All Statuses” menu there is no option to select the status in 4b) (NOT_FOUND keyPath articleId). So there could be more like this that I am unable to find quickly without going through 41 pages of articles.

    4d) The previous and next buttons do not appear when selecting dates. I have to look for the tooltips with my mouse then I can navigate, but as mentioned in 4a) the filter does not seem to function even when I select the correct dates and click the filter button.
    See screenshot
    https://www.dropbox.com/s/4wi87u4jyrasq4j/Screen%20Shot%202018-10-01%20at%203.32.42%20PM.png?dl=0

    Here are our settings. See screenshots.
    https://www.dropbox.com/s/s6pgp2713lt8kp2/Screen%20Shot%202018-09-30%20at%204.32.49%20PM.png?dl=0

    https://www.dropbox.com/s/u0tnem7p102qyek/Screen%20Shot%202018-09-30%20at%204.33.08%20PM.png?dl=0

    The item numbers below are referencing our previous discussion here. It was closed to new replies.
    https://wordpress.org/support/topic/unable-to-fetch-a-list-of-sections-error-and-other-questions/

    2c)
    Yes I understand timeouts can be a problem, but I’d like to at least publish 40 items at a time. This would cut my time in half. Currently, I had 800+ posts. Publishing 20 items at a time and then 20 items and then 20 items, took forever.

    A solution might be, for example, on “Posts” in the WordPress default menu, you can select “Screen Options” and select to show a max of 200 on one page. Do you think we could get a “Screen Options” for your plugin to at least show 40 or 50? My connection is Google Fiber at 1000mbps down and up so even though I may be limited in bandwidth by Apple’s Servers I think I could do 50 at a time without timeouts.

    Building on this, the experience above is time consuming for a second reason, the process:
    * First , after publishing, the “Done” button does nothing, I have to hit the “back” button instead.
    * Then I have to select “Show all Statuses”
    * Then I have to click on “Not Published”
    * Then I have to click on “Apply”
    * Then I have to click on the “Title” checkbox to check all items in the list
    * Then I have to click on “Bulk Actions”
    * Then I have to click on “Publish”
    * Then I have to click on “Apply”
    * Then I have to scroll down
    * Then I have to click on “Publish All”
    * Then I have to start over again for 41 pages of this.

    If we had a “Screen Options” button to show more than 20 “Not Published” items on a page and perhaps if the “Done” button worked (I’m not sure where that button would take me if it worked), this would be literally, 20 times faster.

    Thank you so much for your help!

    Jas

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Kevin – Continued Discussion’ is closed to new replies.