Support » Plugin: Newsletter Sign-Up for CleverReach » Keine Plugin Verbindung- 401; Unauthorized

  • Resolved gabyrau

    (@gabyrau)


    Leider gibt’s schon wieder ein Problem mit der Verbindung zu Cleverreach. Diesmal ist es das Plugin selbst (ich habe inzwischen Version 2.0.2 installiert), das sich nicht verbindet. Im Backend unter “General Settings” kann ich zwar einen Token generieren, aber ich bekomme anschließend die Fehlermeldung “Could not connect to Cleacherreach API. [ 401;Unauthorized ]” – obwohl ich natürlich die richtigen Zugangsdaten eingegeben habe. Ich habe auch mal einen Token direkt mit dem Cleverreach REST Explorer erzeugt und diesen eingefügt – dieselbe Fehlermeldung.

    Auf der Cleverreach-Seite wird WordPress unter “verbundene Apss” angezeigt.

    Dann habe ich es noch mit einem anderen Cleverreach Account versucht und ich habe das Plugin auf einer ganz anderen Website erstmalig neu installiert – jedes Mal dasselbe Problem. Wo kann ich noch suchen?

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hallo, das Problem ist mit dem Update behoben, das vor wenigen Minuten veröffentlicht wurde.

    Im Backend ist nun alles okay. Ich bekomme aber dieselbe Fehlermeldung, wenn jemand versucht, sich zum Newsletter anzumelden …

    Möglicherweise noch ein Cache Problem? Ich habe dies nun auf mehreren Systemen erfolgreich getestet.

    Hallo Hannes, bei mir werden nach der Generierung des Token, in den Integration Settings folgende Fehlermeldungen ausgegeben:

    Warning: Invalid argument supplied for foreach() in /var/www/web40/html/website/wp-content/plugins/cleverreach/includes/class-api-rest.php on line 89
    
    Warning: Invalid argument supplied for foreach() in /var/www/web40/html/website/wp-content/plugins/cleverreach/includes/class-api-rest.php on line 92
    

    Gruß
    Kai

    Ja, war ein Cache Problem. Danke nun funzt alles wieder!

    Hallo Hannes,
    ich habe im Nachhinein noch eine Frage: das Plugin hat ja bis 3.9. einwandfrei funktioniert, dann plötzlich nicht mehr, erst wieder nach deinem Update. Woran lag das? Habe die bei Cleverreach was an der Schnittstelle geändert?
    Danke für kurze Info,
    Gaby

    Hallo Gaby,
    Ja es gab eine Änderung an der Schnittstelle, wobei das Problem mit ziemlicher Sicherheit meine Schuld ist. Ich weiß nicht warum, aber aus irgendeinem Grund habe ich eine falsche Version der Schnittstelle benutzt. Ich dachte ich hätte dies aus der Doku, im Nachhinein konnte ich es aber nicht mehr finden.
    Mir kam das alles irgendwie ziemlich absurd vor, aber nachträglich werde ich ohnehin nicht mehr herausfinden wie es dazu kam.
    Grüße, Hannes

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Keine Plugin Verbindung- 401; Unauthorized’ is closed to new replies.