Support » Plugin: Smush Image Compression and Optimization » Keeps saying you have images that need re-compressing

  • Resolved Chris

    (@web2guru)


    I use WP Smush on several other sites with no problems, so thanks for the great tool!

    However I have run Bulk Smush Now and Re-check Images several times on a new site, and it always comes back the same. There are 95 images, so it took two runs to get them all done, but it continues to says there are still 8 that need to be smushed. (Everything is up-to-date, WP 4.6.1, WP Smush 2.4.5)

    I found someone else with a similar problem (https://wordpress.org/support/topic/after-smushing-no-change-in-google-pagespeed/ – disregarding the Google PageSpeed stuff), but they stopped responding, so here is a new thread with screenshots and settings.

    Automatic smushing and resize original images are both turned on…

    http://i.imgur.com/ipv7VBP.png

    It appears to be smushing…

    http://i.imgur.com/0nOLZ1P.png

    After bulk smushing, it says all images are smushed on the left but says 93/95 images smushed in the stats on the right…

    http://i.imgur.com/hQE8ECt.png

    If I refresh the page, the left side says you have two images that need re-compressing…

    http://i.imgur.com/yTXm1oj.png

    If I re-check images, it says you have 8 images that need re-compressing on the left and 87/95 images smushed in the stats on the right side…

    http://i.imgur.com/DR3gh6e.png

    Looking in the media library, all images are either smushed or already optimized (there are 9 that say they are already optimized)…

    http://i.imgur.com/dCPBDqf.png

    If it is a file size issue (over 1MB), is it not supposed to say it skipped them? It would be nice to see which ones they are. It would also be great if it would list which ones it is saying still need to be smushed.

    More than half of those images are from the theme demo content, and a most of those appear to be from Depositphotos. We will probably delete most of them, but I am guessing that 8 are over 1MB. All of the images that say they are already optimized are from the demo content too.

    • This topic was modified 1 year, 6 months ago by  Chris. Reason: image links displayed images instead of links
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Umesh Kumar

    (@umeshsingla)

    Hey @web2guru,

    First of all that’s a very nice and detailed thread 🙂

    Coming to the issue, I’d directly jump into debugging instead of trying this and that and for that I’d need you to contact us through https://premium.wpmudev.org/contact

    You’ve to select “I’ve a different question” from dropdown, mention “Attn. Umesh Kumar” in subject and add a link to this thread in message and submit the form.

    I’ll take it further from there itself.

    Cheers

    Yes, I read the other thread and figured I would include everything you had asked for.

    Thanks for the quick response! I have submitted the question in the contact form.

    Plugin Author Umesh Kumar

    (@umeshsingla)

    @web2guru, As per our conversation over the email, the issue is now fixed for you.

    So I’ll mark the thread as resolved.

    Cheers, Umesh

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Keeps saying you have images that need re-compressing’ is closed to new replies.