Support » Plugin: Ultimeter » Keep $ with custom setting in Pro version

  • Resolved ssetnaek

    (@ssetnaek)


    I just purchased the Pro version after reading the “Plugin Glitch” post above because I wanted to remove the decimal point and cents from the dollar amount on the thermometer. However, now I can’t show a currency symbol. I can add commas to the amount raised but if I add in the currency symbol before the amount the thermometer won’t rise. Is there something I’m missing?

    EDIT: Oddly enough it works great if I add the currency symbol after the amount — but that isn’t what I need 🙁

    • This topic was modified 1 year, 4 months ago by ssetnaek.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author bouncingsprout

    (@bouncingsprout)

    Hey ssetnaek,

    That all seems like expected behaviour. In the ‘plugin glitch’ post, my advice was to use the custom unit feature to allow 2000000 to be displayed without trailing zeros. So in essence, it removes any notion whatsoever of currency. The custom unit feature (as you’ve pointed out) only allows adding a unit afterwards. You are also right to point out that putting a currency symbol inside the value box breaks the maths as it isn’t a real number!

    The answer here would be to offer the option to remove the decimal point and trailing zeros from the currency method. I will add this to the list of planned features for the next version, but it may take a couple of weeks to code (but likely a lot less). I hope that’s okay?

    If you have any further questions, I can be reached via the contact form within the Ultimeter settings screen, or of course by email.

    Regards,

    Ben

    Plugin Author bouncingsprout

    (@bouncingsprout)

    Further to that,

    I may have a crude fix for you, while waiting for the next version. You will need to add the following in the custom CSS box in the pro version:

    .upgm_meter_amount.upgm_thermometer_amount.upgm_custom::before {content: “\0024”;}

    If it doesn’t work, please email me a set of login details for your site and I’ll add the code personally. It effectively fools the plugin into showing a currency unit before the number, even though that number has nothing to do with ‘currency’.

    Good luck!

    Plugin Author bouncingsprout

    (@bouncingsprout)

    Just a quick note to say that version 1.9 Pro is available now and has support for disabling the decimal point and trailing zeros.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Keep $ with custom setting in Pro version’ is closed to new replies.