Support » Plugin: Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos & Others » Keep Getting 404 Error Message using SmugMug

  • Resolved toodles53562

    (@toodles53562)


    I am trying to use your plugin to connect to a Smug Mug Account and I have gone in an gotten the appropriate API keys and secret key.
    When I got to enter in my gallery, I keep getting a “No data returned. Error code 404”
    I have been trying to get this to work for hours and I am at a loss. Please help.
    https://ohshootphotos.com/family-portfolio/

    The page I need help with: [log in to see the link]

Viewing 5 replies - 16 through 20 (of 20 total)
  • It’s happening on all of the pages I have the plugin embedded.

    https://ohshootphotos.com/children/
    https://ohshootphotos.com/family-portfolio
    https://ohshootphotos.com/seniors

    Thank you.

    Plugin Author Sayontan

    (@sayontan)

    OK – there is one setting: Photonic → Settings → SmugMug → SmugMug Settings → Tile image size (the Tile size option is also available when you are creating the gallery; if you are using the shortcode the option is tile_size, and I can provide you with more details in such a case). The default is set to “Same as Main image size”, which in turn is set to a default of “Largest”.

    If you set the tile size to be something that is “Medium”, but leave the “Main Size” to “Largest”, this is what will happen:

    • The justified grid will use the “Tile size” and will pull significantly smaller images. This will make your page load a lot faster (each image will be at least 75% smaller).
    • When you click on an image to show a lightbox it will show the full-resolution image, but this will only happen one image at a time and will not impact overall page load time, while keeping a good resolution image for display.

    Yes, I am using the shortcode, can you provide the shortcode for the tile size medium?
    Thank you

    Plugin Author Sayontan

    (@sayontan)

    You can set the global option (i.e. Photonic → Settings → SmugMug → SmugMug Settings → Tile image size). You don’t have to modify individual shortcodes, then.

    Just for reference, though, these are the permissible values (these are case-sensitive):

    • Tiny
    • Thumb
    • Small
    • Medium
    • Large
    • XLarge – Extra large, not always available
    • X2Large – Extra large 2, not always available
    • X3Large – Extra large 3, not always available
    • 4K – 4K, not always available
    • 5K – 5K, not always available
    • Original – Not always available
    • Largest – Generally the safest option for the main image size

    That solved it, thank you so much!!!
    I have to say, you have been incredible helping me through these issues I had and I am loving your plugin.
    Thank you for being so responsive and helpful.

Viewing 5 replies - 16 through 20 (of 20 total)
  • The topic ‘Keep Getting 404 Error Message using SmugMug’ is closed to new replies.