Support » How-To and Troubleshooting » Keep getting 403 error when trying to edit page

Keep getting 403 error when trying to edit page

  • I went into my WordPress admin panel and tried to edit a page, but when I clicked Save I got this message:

    “You don’t have permission to access /petblog/wp-admin/post.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    I opened up my FTP program and made sure the permissions for the entire blog directory were set to 755, but I still get the error. As a test, I also set post.php to 777, but that didn’t work either.

    Any ideas would be greatly appreciated, I’ve been trying to fix this for an hour or so and I’m ready to smash something! 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • Did you recently make any changes to your .htaccess file because that could be a problem if it is not permissions or folder ownership on the server.


    No, I didn’t touched the .htaccess file.


    Then it must be because your host has mod_security. Check out the following:



    It’s weird though, because all I’m doing is changing “December 1, 2006” to “December 31, 2006” on the page.

    Anyways, I went through and found out the problem on the pagr was a mailto: link. Weird.

    Anways, thanks for your help. It’s appreciated! 🙂

    Excellent….I learned something as well. Good to know.


    Hi —
    This topic describes what is happening to me, and I’ve tried just posting the word “testing” and I still can’t save a post.

    Additionally — I now can no longer access *any* function of WordPress. I get the same error as described above for admin, login, etc. In short, the entire program is non-functional at this point. (Though I did install it just fine. I did start to add links, etc. and then I finally decided to write a post and it was all bad from there on.

    Again, only thing in my post was the word “testing”. Any help appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Keep getting 403 error when trying to edit page’ is closed to new replies.