Support » Plugin: WordPress Knowledge base & Documentation Plugin - WP Knowledgebase » KB page losing left widgets and not presenting right

  • Resolved MyWifesGeek

    (@xperiment)


    The page that I am putting the KB shortcode on is dropping the left widget column and the KB data is misaligned. and no page title is displayed.

    I have tried the auto-generated page and created my own. The manually created page shows the title but not the left widget column and everything is still left shifted.

    I have seen some talk of manually editing the PHP but surely an update is more desirable in the long run.

    Other than this issue this is a great plugin.

    Thank you,
    Gary

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Maeve Lander

    (@enigmaweb)

    Hi Gary,

    Sidebar
    1.) Have you set it to show the sidebar in your KB Settings?
    2.) Have you added widgets to the sidebar via Appearance > Widgets?

    Data is misaligned

    Can you explain what you mean by this? Point me to a page or show a screenshot?
    Thanks.

    I have seen some talk of manually editing the PHP but surely an update is more desirable in the long run.

    I think you are referring to this thread. But I do not think this is relevant to your issue. I actually haven’t been able to replicate the problem this thread mentions, and neither of the users in that thread have posted screenshots or links so I can’t even see the issue they are referring to. Therefore, no action has been or will be taken on this. And like I said… I don’t think it sounds like your issue anyway.

    Thread Starter MyWifesGeek

    (@xperiment)

    I put the page in the initial message…

    The page I need help with: http://www.brickscascade.com/knowledgebase/

    If you look at any other page on the site (other than the home page) you can see that I have a sidebar with widgets configured.

    I turned on the sidebar in the KB settings and things shift over a bit but it is just white space. Additionally the search bar isn’t positioned right.

    Plugin Contributor Maeve Lander

    (@enigmaweb)

    It looks like the correct position/layout to me, but with an empty sidebar. Are you sure you actually put the widgets into the sidebar? It’s a different sidebar labelled “Knowledgebase Sidebar” where you would actually need to create widgets in order for something to show there… Can you check it please?

    Search > what do you mean, ‘it isn’t positioned right’. It’s at the top, aligned left, which is exactly where it’s intended to be. Perhaps you mean ‘it’s not positioned where I want it?’ Could you explain where you want it? It is likely achievable easily with some CSS. Or perhaps you may like to turn OFF search in the settings, then add the search widget to your KB sidebar instead? This might work best just judging on your design…

    Thread Starter MyWifesGeek

    (@xperiment)

    I didn’t catch that there was a distinct sidebar just for this plugin. Seems counter-intuitive. But when I put the widgets in they did show up.

    I took screen shots of how the KB page looks in comparison to the other pages in the site but I don’t see a way to attach them to this post.

    Plugin Contributor Maeve Lander

    (@enigmaweb)

    Ok http://www.brickscascade.com/knowledgebase/ is now looking pretty good.

    Any customisation of the styling can be easily achieved with CSS. For example, let’s give your search at the top a bit of space at the top:

    .kbe_search_field {
        margin-top: 56px !important;
    }

    It might look nice if we extend the search to full width too I think:

    .kbe_search_field input[type=text] {
        width: 100% !important;
    }

    Let’s widen the body content to match the width of your other page templates and adjust the width of the right content area to play nice within that:

    #kbe_container {
        width: 1140px !important;
    }
    
    .kbe_content_right {
        width: 75% !important;
    }
    Thread Starter MyWifesGeek

    (@xperiment)

    THose adjustments make it look better but it doesn’t make it conform to the rest of the site.

    I have put the images here so you can see what I am seeing
    https://1drv.ms/f/s!As7SnU89agJ2lZ41rMvoab_9Y2gjOg

    About page = how the other pages in my site look.
    KB page & kb page no search = what the short code output looks like on the page named “knowledgebase”
    KB on new & no search = what the short code output looks like on a manually created page
    misaligned footer = what happens with the short code on a manually created page. Notice the “1” showing up like I have read about in some other posts.

    Thread Starter MyWifesGeek

    (@xperiment)

    Sorry, the page with the funky footer is here…
    http://www.brickscascade.com/kb-test/

    Plugin Contributor Maeve Lander

    (@enigmaweb)

    As you have seen from my last reply, all manner of customisation can be done by tweaking CSS and the plugin has an advanced templating system if you need to adjust layouts more heavily (eg adjusting the page template to work with the structure of your theme wrapper and footer)

    The WP Knowledgebase is looking and functioning exactly as intended on your site. it’s not possible to make such a complex plugin be 100% perfectly conforming with every possible theme out there…. That is why it has a templating system – so that you can tweak those templates to work perfectly with your own theme. Please see FAQs for more details and if you are not a developer yourself, you may want to employ one for a few hours to help you get it pixel perfect with your theme.

    What was the solution for the “1” appearing below the footer? I’m having that exact issue and I haven’t edited any template files what so ever.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘KB page losing left widgets and not presenting right’ is closed to new replies.