Support » Theme: Virtue » Kadence Virtue theme NOT compatible with Internet Explorer 9

  • I was initially really excited about this theme due to the easy customization options. I still am. BUT…. when I decided to check out my site in IE after putting in several days of work (I normally use Firefox), I discovered to my dismay that it does not display correctly at all:
    1. Topbar is the wrong color
    2. Topbar widgets do not display correctly, and the floating shopping cart icon only has its edge visible.
    3. Header is not displaying its assigned color.
    4. Body is not displaying its assigned color.
    5. Background is not displaying its assigned color.
    6. Footer is not displaying its assigned color.

    On top of all that, when I open the WordPress admin in WP and try to customize the theme, it is simply not possible, and displays a messed-up non-working interface.

    Things I have tried to solve the issue:
    a) Install the Respond.js WordPress plugin, which should take care of many of the compatibility issues
    b) Force IE to behave as earlier versions by placing differnt scripts into the theme’s header.php file. I have tried all of the following separately of each other:
    <!–DVFMTSC–><meta<!–DVFMTSC–> http<!–DVFMTSC–>−equiv=”X<!–DVFMTSC–>−UA<!–DVFMTSC–>−Compatible”<!–DVFMTSC–> content=”IE=EmulateIE8″<!–DVFMTSC–> <!–DVFMTSC–>>
    and
    <meta http-equiv=”X-UA-Compatible” content=”IE=EmulateIE7? />
    and
    <meta http-equiv=”X-UA-Compatible” content=”IE=9″>
    and
    <meta http-equiv=”X-UA-Compatible” content=”IE=EmulateIE8″ >

    Nothing. It’s all still messed up in IE9. I don’t have earlier versions of IE to test with, but I suspect it doesn’t matter much – it should also work in IE9. Even though we all know what a horrible and buggy browser IE is to begin with.

    Has anybody run into similar issues and been able to solve them? Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hey Mis_Tral,

    Can you post a link to your site so that I can test please?

    Thanks!,
    Kevin

    Thread Starter Mis_Tral

    (@mis_tral)

    Hi Kevin,

    Thanks so much for looking into this! This is my development site. Please excuse the mess, it’s work in progress. http://www.ttkonsult.ee/v-belWP/

    Alright, I’ve viewed your site on both a mac in safari chrome and firefox, as well as chrome and internet explorer on a pc, and the site is displaying the same colors and widgets across all screens.

    Can you take some screenshots of your issue and share them so i can see what you’re seeing?
    https://postimage.org/

    Also, be sure that you’re clearing your cache after making changes to the site. Otherwise there may be a delay from when you’ve made the changes to when they actually show up on your site.

    -Kevin

    Thread Starter Mis_Tral

    (@mis_tral)

    Thank you once again! It is really helpful. Maybe I should then just not worry too much, as the chances that there is somebody with a configuration as odd as mine should be slim? Perhaps I could use the EU mandatory cookie notification to also inform of potential IE issues. Anyway, here is what it *should* look like so far (meaning with the work already done on it):
    https://postimg.org/image/rnh0oyt6v/

    This is what it looks like in my IE9:
    https://postimg.org/image/kzj6esbq7/

    And this is the admin end of things in IE9:
    https://postimg.org/image/4o0dl8crh/

    I have attempted to clear the cache repeatedly, and also always refresh the page with Ctrl+F5 after changes.

    Ah I’m on IE11 on my device, so it appears different when I view than when you do. Any reason you’re using IE9 at the moment?

    I personally wouldn’t worry about how things appear on IE9, since any users of it should’ve updated their browser by now, but when the theme dev sees this thread, he’ll have more input as to the best way to handle this.

    Sorry I can’t be of more help at the moment!

    -Kevin

    Thread Starter Mis_Tral

    (@mis_tral)

    Thanks once again for your time spent on this issue. IE is not my regular browser of preference, so I just happened to have whatever version I had at the moment. As you can infer, I’m not normally using it unless there is a specific reason to do so. Which is why I happened to have IE9.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Kadence Virtue theme NOT compatible with Internet Explorer 9’ is closed to new replies.