WordPress.org

Support

Support » Installation » K2 Users on WP 2.0 with Problems

K2 Users on WP 2.0 with Problems

  • I am not sure have anyone found a way to fixed the problem when you upgrade to WP 2.0 and have a problem using K2 theme but i have found a way so i am sharing with you all!

    When you upgrade you will see


    WordPress database error: [Unknown column 'user_level' in 'where clause']
    SELECT COUNT(*) FROM wp_users WHERE user_level > 1

    This is because they have change user_level to user_status what you can do is just change user_level in theloop.php in K2 folder to user_status !

Viewing 3 replies - 1 through 3 (of 3 total)
  • Heh. That’s an easier fix than what I came up with… I just re-added the “user_level” field to the database table 🙂

    Thanks for the heads-up!

    You would be well-advised to post this at the K2 support forum as well. K2 is essentially a “fork” of wp, and as such is not “supported” herein…. though it is appreciated that you’ve posted fixes in case others should look for a solution to the same problem.

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘K2 Users on WP 2.0 with Problems’ is closed to new replies.
Skip to toolbar