Support » Plugin: Gutenberg » Justify text

  • andrespaiva

    (@andrespaiva)


    The plugin does not allow editing in justified format in visual mode, it is necessary to touch the HTML. Why? Why? Why?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Marius L. J.

    (@clorith)

    In general, justified texts have poor implementations that differ between browsers, leading to a less than optimal user experience, as such it was removed in WordPress 4.7 (along with the underline option), and we’ve carried that forward into Gutenberg as well.

    That being said, there’s a plugin that introduces more control to the paragraph blocks for those that need that, and justification is one of the features it implements. You can check it out at https://wordpress.org/plugins/advanced-rich-text-tools/

    andrespaiva

    (@andrespaiva)

    Interesting, I did not know that you could do that. I just hope it does not have compatibility problems in the future.

    Thank you Marius

    andrespaiva

    (@andrespaiva)

    Unfortunately I installed the plugin but it does not contain the option to justify text.

    Moderator Marius L. J.

    (@clorith)

    Hmm, I must have glanced over it and been mistaken, I do apologize for that.

    I’m afraid I don’t know of any direct approach at this time then, perhaps one of the many other plugins that introduce advanced blocks has it, but I’ve not tried them so I can’t say for certain.

    I wanted to throw my 2ยข worth in here. The author of the TinyMCE Advanced https://wordpress.org/plugins/tinymce-advanced/ mentioned somewhere, I wish I could remember I would post the link, he mentioned after someone asked him if TinyMCE Advanced would support Gutenberg and he mention it would, maybe under a different name. But we have used TinyMCE Advanced for several years and it was (still is) a great plugin.

    Maybe if you contact Andrew Ozz, the Developer, he could shed some light on those plans with Gutenberg.

    OK, it was bothering me where I saw that here is the link to the discussion about TinyMCE Advanced and Gutenberg.
    https://wordpress.org/support/topic/continued-development-of-tinymce-advanced-after-gutenberg-becomes-default/

    Enjoy

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Justify text’ is closed to new replies.