Support » Plugin: FooGallery - Image Gallery WordPress Plugin » Justified not loading correctly with https until refresh

  • Resolved generalnumpty

    (@generalnumpty)


    My Justified gallery’s are not loading correctly with until I refresh the page or leave the page without refresh and then come back to the page. This is within https but if I view them under http then they are ok.
    The images appear in 1 long column overlapping each other.
    In foogallery settings I have tried clearing the html cache – even though Enable HTML Cache is not ticked.
    Also I have tried and Cleared CSS Cache.
    I do not have any cache plugins.
    Have tried disabling foogallery and – re enabling.
    Clearing cookies and all site settings on pc and phone.
    Ticking force original thumbs.
    After clearing the CSS Cache in settings the gallery’s seem to all load ok until the next day and they are all wrong again. Tested on safri, chrome pc fire fox pc android phone apple phone. @bradvin you already have my website from my email to you last week.

    These are my plugins
    Active Plugins : Array
    (
    [0] => foogallery/foogallery.php
    [1] => a3-lazy-load/a3-lazy-load.php
    [2] => classic-editor/classic-editor.php
    [3] => lightbox-photoswipe/lightbox-photoswipe.php
    [4] => regenerate-thumbnails-advanced/regenerate-thumbnails-advanced.php
    [5] => tinymce-advanced/tinymce-advanced.php
    [6] => updraftplus/updraftplus.php
    [7] => wordpress-seo/wp-seo.php

Viewing 5 replies - 1 through 5 (of 5 total)
  • Update. I am still testing but I have seen an improvement when I disabled a3 lazyload. It may of been upsetting foogallerys own inbuilt lazyload but I am still seeing some gallery’s on some devices not loading correctly even with a3 lazyload dissabled.
    If I disable foogallerys lazyload and only use the a3lazyload then the gallery’s do not display properly BUT not as bad as with both lazyloads running.
    And in any case with a3 lazyload + foo’s lazyload running the problem is not on every gallery even after clearing the cache.
    I still need an extra lazyload plugin because I also have images on page’s that also have a foogallery.
    The ideal situ would be to find a lazyload plugin that plays nice with foogallery so I can disable foogallerys one and globally use the extra lazyload plugin.
    I would really appreciate some help and any advice/ guidance/ ideas to try on this from anyone please.

    @bradvin I have noted that you have picked this up – thank you.
    After a few days of testing with the a3 lazyload disabled the gallery’s still do not load correctly until a refresh or I re visit the page then the next day or so do not display again.
    In my media settings I had it set to 0 for thumbs 0 for med and 1200 x1200 for large. Because my theme was still creating images at my 12×800 upload size and also 300×200 / 768×512 / 1024×683. And I have uplaodes over 2,000 images and was trying to cut down on all the extra unneeded sizes.
    I will test using all the default WP media settings and do a regenerate thumbs.
    But still do not understand why the behaviour is only present under https.
    Would appreciate it if my website was not posted in any reply please.

    • This reply was modified 8 months, 3 weeks ago by generalnumpty.
    Plugin Support phillcoxon

    (@phillcoxon)

    @bradvin – just tagging you in to ensure you’re aware of this support thread. I believe you’re already helping @generalnumpty via email?

    Plugin Author bradvin

    (@bradvin)

    This has been resolved with @generalnumpty via email

    Sorry bradvin yes as far as I can tell it is all now fixed with a MASSIVE thanks to you. It was always going to be something wrong at my end because there are thousands of happy foogallery uesers.
    bradvin was able to diagnose the problem which was that in my stupid ignorance I though just activating my ssl certificate was all I needed to do. This left me with mixed content which was upsetting the gallery’s. I changed both wp and website name in wp settings to be https as they were still http. Then I had to use better search and replace to sniff out all of the instances of http. All of this was after bradvins advice.
    Thank you Foo-brad

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Justified not loading correctly with https until refresh’ is closed to new replies.