Support » Plugin: Meow Gallery (+ Gutenberg Gallery Block) » Justified Layout “Gutter” not working on category pages

  • Resolved bluisier

    (@bluisier)


    Hi guys,

    Still very happy with the pro version of your plugin (by far the best gallery plugin in my opinion)

    I have a small issue with the Justified layout on category pages though. I defined a “Gutter” of 3px for the justified layout and it works perfectly on posts or pages (which means that the class=”mgl-item” has margins of 1.5px which overwrite the default 20px). But unfortunately, if I insert a gallery on a category page (description of the category), the defined gutter doesn’t work and I still have a 20px margin (you can see it in the gallery at the end of the linked page)

    Is this behavior on purpose? Should I make this work with some CSS tweaks for my category pages?

    cheers

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor Thomas

    (@kywyz)

    Hello @bluisier,

    Sorry for this late reply!

    So I had a look at your category page, indeed, the custom margin is not applied, and the reason is because in the <style> above the gallery, there are some random <p> tags hanging around causing this CSS to be non-valid. But that’s where the custom margin is declared hence the issue.

    Now, I’m not sure why these <p> tags are only appearing on the category page, any ideas @tigroumeow ?

    Best regards,
    Thomas

    Hi @kywyz and @tigroumeow ,

    Yeah you’re right. I had a look at some of my custom theme files to see if I could be the culprit but I could not solve the issue. As a side note I’m using your filter “mgl_sizes” to customize the sizes attr of the galleries but it should not have anything to do with that.

    Best Regards

    Benoit

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hi @bluisier,

    For some reason, it looks like the wpautop process is applied to your HTML. This process converts the line breaks into… HTML paragraph. It’s often disabled by themes, as it causes many issues. But even that, it shouldn’t be applied to inline CSS. The fact it only happens to the category pages is another mystery, but maybe they properly disabled that process on the posts/pages but didn’t think about doing it globally.

    I might have one solution. Could you edit one of the plugin files? In builders/builder.php, replace this:

    $inline_css = $this->inline_css();

    by this:

    $inline_css = $this->inline_css();
    $inline_css = preg_replace( "/\r|\n/", "", $inline_css );

    I believe it might work. 🙂

    PS: Thanks for saying all those good things about Bordeaux, by the way! In fact, my hometown is where the dune is…

    Hi @tigroumeow ,

    Thanks for your reply. Everything is clear now! Actually the content I’m displaying in my category pages is the taxonomy_title_description of the Genesis framework. So I checked in Genesis code and in the function genesis_do_taxonomy_title_description(), they run the content through wpautop which causes the issue.

    Unfortunately, there is nothing I can do to disable wpautop (I could contact the genesis team in fact 😉 ) but I tried your fix and it works perfectly. Do you think you can add this to the next update of the plugin?

    P.S. Ohh so you come from La Teste I guess! We did a cool beer hike there that goes to the dune and ends up in the Burdigala brewery. But we really loved all the area and the city of Bordeaux itself.

    Plugin Author Jordy Meow

    (@tigroumeow)

    Hi @bluisier,

    Yes, I guess I can keep this in the plugin, to avoid this to happen. Anyway, I’m glad that little fix worked! 🙂 If any issue like this in the next updates, tell me and I’ll fix it.

    By the way, don’t hesitate to write a little review for this plugin if you like it 🙂 That helps us a lot.

    PS: Arcachon actually, but La Teste was the town of my primary school, music school, etc! This area is lovely, I would like to spend more time to actually discover it (though I am a bit far now).

    @tigroumeow ,

    Of course I wrote a review already (https://wordpress.org/support/topic/best-gallery-plugin-for-wp-by-far/). You guys developed by far the best gallery plugin available on wp so far. I will also write a blog post as soon as I have some time on my company blog.

    Best

    Benoit

    P.S. good luck for the book about Japanese villages

    @tigroumeow ,

    I’m reopening this issue as I still have the problem (<p> tags in the <style> above the galleries) on my category pages. Did you integrated the fix in the plugin?

    Best

    Benoit

    Plugin Author Jordy Meow

    (@tigroumeow)

    I am sorry, indeed! It was not part of the new versions. I have just applied the change to the source code, and it will be part of the new releases 🙂

    @tigroumeow no worries! Thanks a lot for the change.

    BTW, I just subscribe to your affiliate programm and I’m about to write a blog post about your plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.