Support » Plugin: Restrict Widgets » Just Works

  • I know this plugin has net been updated recently but it seems to always just work flawlessly. Working with WP 4.9.8

  • You must be logged in to reply to this review.