Support » Installing WordPress » Just won’t install, I gave up

  • * WordPress crashed Apache 2 on my Windows test box, every single time. The first PHP script I ever seen that crashed Apache on this box.
    * It didn’t install on my Windows PHP 5 test machine (see below)
    * It didn’t install on my old PHP 4 Linux webserver (see below)
    * Ir didn’t install on my new PHP 5 Linux webserver (see below)
    * Install never worked, always hung on step 3, with no message of what went wrong. All files had full write privelages, and database details were set correctly, just did not work.
    * The code is too bloated for my likings, too many files, it makes it very difficult to intergate it into my site, where I may not want to use the WordPress default layout
    * Tables!
    And I am not an idiot, but if I can’t get this going, as a intermediate to advanced PHP/MySQL programmer, there must be something wrong with this 5 minute concept. I am sure newbies will hit this same brick wall.
    I just started to write my own blog engine in the end, which is simple, and just works.
    Sorry about this, but it just would not work for me.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I can’t disagree with your experiences, but I can say that with one exception(1), I have installed WordPress dozens of times without any hitches at all, and in every case I have found that the actual install takes less than 5 minutes.
    This includes installing to php4.x and php5, and I’ve been using and installing since version 1.0.1 (January that came out).
    WordPress can also be integrated into any layout as the only essential part of the ‘engine’ for display purposes is ‘The Loop’.
    In all those efforts, did you get any error messages at all ?

    No, I diddn’t. Should really register, sorry, I just was frustrated, after weeks of trying…
    The url where I wanted to “add” WordPress as a blog engine is where basically the current “Blog” or more like “news” is just two tables in a MySQL database, that I created myself, with some really basic self done code.
    But if it is possible to integrate WordPress, I will have another crack at it… sigh, but yeah, I got no messages at all at step 3, it would basically complete step 2, then have a blank page, with “Step 3” heading on it, but nothing below that.
    I have been trying to use 1.2 stable, as I was reluctant to use a CVS version just yet.
    If it works, that will be great, because I did a similar sort of intergration with YAPPA for my gallery, I was hoping to achieve the same with WordPress.
    The only thing I am worried about, is if I do integrate it, will it be easy enough to upgrade, without massive recoding. hmm

    Here is the info on ‘The Loop’
    I haven’t integrated WP with anything, but very many people here have – take a look at and David’s CGFeedRead ( ). Many people have used that to integrate a variety of things into their blogs or other pages.
    Did a server error log hold any clues ?
    I’m know zero php, but I have seen other people using ‘die’ statements to try and narrow down the error – might that be of use ?
    Keep posting, and we’ll do everything we can to get you up and running…

    Will have a go tonight, and tomorrow. I do know that the MySQL is working, because the wp_ tables are created in the database, I can see them in PHPMyAdmin.
    The blog also sort of works, even though step 3 did not give me any finish information, I can still see a blog that apears functional.
    But because step 3 did not finish, I do not know the password to post to the blog, so I do not know if it is functional after that, maybe it is… and just need this password. I just didn’t know how many steps there are in total, because of this stopping at step 3.

    The password is sortable from here:
    And step 3 should give you your password, with ‘admin’ being the user, and a link to the wp-login.php page which is in the main wp directory.

    Right, thank you, I have set up:
    and can log into the admin too… now I will be spending the next few days setting up the loop, so the log is really located:
    hope it will work 🙂
    As for the cutting of part during step 3 of setup, I looked at the HTML source it generated, and basically the HTML was simply cut short, like this:

    <h1>Step 3</h1>
    and no more HTML code after that point, that was the cut off, strange 🙂

    I had to sort out a number of password problems, and I think there’s an easier method that using the MD5 hash generator.
    On this line:
    user_pass varchar(64) [where the password appears at the end in MD5]
    I simply selected a function – the fifth column in that line – of MD5 and typed the password in as normal English at the end. PHPmyadmin then converts it.
    Worked everytime for me! :o)

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Just won’t install, I gave up’ is closed to new replies.