Support » Plugin: SuperCPT » Just upgraded to WP 3.6 and getting the following error

  • Resolved popstalin

    (@popstalin)


    Warning: require_once(__DIR__/includes/scpt-helpers.php) [function.require-once]: failed to open stream: No such file or directory in /wp-content/plugins/super-cpt/super-cpt.php on line 32

    However, I’ve uploaded the plugin a second time and I’ve looked at the folder structure and nothing is missing.

    http://wordpress.org/plugins/super-cpt/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Same, it worked perfectly before. Since I updated the wordpress 3.6 and superCPT 0.2, the Post Meta Boxes do not show any longer. I can still see the saved meta data by showing the Custom_fields but the Super CPT just does not work completely. I cannot see the registered fields in creating the new post.

    Thanks.
    http://wordpress.org/plugins/super-cpt/

    Same here too! The same message shows for me after I try to activate the SuperCPT plugin. I thought that it’s happening because my not so good server, but I’ve just changed the server, did a new WordPress install, and the same is happening.

    http://wordpress.org/plugins/super-cpt/

    Plugin Author Matthew Boynes

    (@mboynes)

    Thanks for bringing this to my attention. I was having trouble replicating this issue, but realized that __DIR__ isn’t available to PHP < 5.3. I pushed up a fix that should resolve this for you. Can you update and let me know if all is well?

    Thanks!
    Matt

    Hi Matthew! I’ve just upgraded it and now it works! Thank you!

    Plugin Author Matthew Boynes

    (@mboynes)

    *Whew*, glad that was it. Thanks for testing it so quickly, I really appreciate it!

    Cheers,
    Matt

    Hi Matt, thank your for your update. I updated the latest version of SuperCPT. However, the issue still exists. When I open a specific post, the meta boxes do not appear. I cannot find the meta box while creating a new post as well.

    I used SuperCPT with the following process:
    1.I registered the custom post type before I knew superCPT.
    2.I got to know superCPT and installed it.
    3.I used ‘new super meta box’ function to support my existing posts and it worked perfectly.
    4. When wordpress updated to 3.6, the superCPT no longer support my existing post type any longer

    Cheers,
    Chaoster

    Plugin Author Matthew Boynes

    (@mboynes)

    Hi Chaoster, can you please share all your relevant code? Putting it in a gist or similar and linking to it would be best.

    Thanks,
    Matt

    Hi Matt,

    Thank you for your patient reply.

    Basically, it’s my personal online portfolio. Here are the two pieces of codes I wrote in the function.php file.

    https://gist.github.com/anonymous/6295026

    Cheers
    Chaoster

    Plugin Author Matthew Boynes

    (@mboynes)

    My hunch is that there’s a race condition whereby the meta is being defined before the post type. You can try setting the priority on the init hook to 9 to test this out.

    Overall, though, you’re missing most of the flavor of the plugin. You should review the docs here: https://github.com/mboynes/super-cpt/wiki and be sure to watch the video here: https://vimeo.com/59368054 and convert your register_post_type call to Super_Custom_Post_Type

    Cheers,
    Matt

    Thanks Matt, yeah I know, I watched the video and read the doc before, as the Super Custom Post Type and taxonomy are very powerful features, I will eventually convert them to a all super CPT generated codes. They gonna look tidy and functionally more powerful. Let me try the priority setting first, appreciate for your help.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Just upgraded to WP 3.6 and getting the following error’ is closed to new replies.