Support » Fixing WordPress » Just upgraded to php 5.4 and site doesn't work!

  • The IDIOTS at sent me an email to upgrade to php 5.4 today from 5.2, and after I did, my site won’t come up!

    I called and they said I needed to upgrade wordpress(Should have told mentioned it would not be compatible). How do I do that when site is screwed up???


Viewing 15 replies - 1 through 15 (of 19 total)
  • I just called and they said I need to reinstall. I hope it won’t screw up my site!!!

    This is the exact error:

    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at db— This could mean your host’s database server is down.
    •Are you sure you have the correct username and password?
    •Are you sure that you have typed the correct hostname?
    •Are you sure that the database server is running?

    And it shouldn’t screw things up — all your content is in the database and the wp-content folder, not in the core WP files. SAVE a copy of the wp-content folder, and if the manual update instructions don’t work, be sure to use the same db as you used before.

    Just upgrading PHP shouldn’t have changed anything about your database login info. Doublecheck that you’re using the same information you were before, and then check with 1and1 to see if that changed at the same time as the PHP update (for instance, if they moved you to a new server in the process).

    Again, this shouldn’t have happened, but it’s possible that either you overlooked a bit of info in their message, or that they didn’t tell you everything you needed to know to do an upgrade when you called them.

    And good luck. This kind of thing really sucks to go through 🙁

    Same thing here. You can go back to 5.2 via 1&1 panel. Worked for me while I sort out what to do. Complete reinstalls on two sites did NOT work.

    Same problem here, moving back to 5.2 via the 1&1 panel helped, but it’s only a temporary option. However I couldn’t identifiy the cause yet. Deleting all my plugins didn’t help, neither did switching to the standard theme. I didn’t try a reinstall. Any ideas?

    Problem solved: update your mySQL-database password, update the new password into your wp-config.php, wait a few minutes and done! Hope that works for you as well!

    Apparently php5.4 can’t handle database passwords created pre mySQL 4.1, though I’m just paraphrasing here:

    Confirmed, ffreundt. Thanks for finding it!

    If update password, do I still have to also update WordPress too?

    You have to update the password in your wp_config.php, of course. But I don’t know which WordPress version you need to run php4.3, mine was already updated to the most recent WP version. It never hurts though to run a current version 😉

    I had this same problem, but just another note that you don’t actually have to change your password in wp-config.php. Just go to mySQL Administration at 1and1 and re-enter the same password you’ve always used (the same one in your wp-config). Once that updates you should be good. Thanks to:

    I had the same problem and thanks to this thread the solution is to simply change the password in the MySQL database admin at 1and1. Use the same password you have the wp-config.php set at. Within a few minutes it works. Thanks so much for this thread.


    Bluehost hosts my Web site. I changed my MySQL password in the database and wp-config.php file just to be sure. After that I upgraded to PHP 5.4 (Single php.ini).

    Thank you, this thread is a lifesaver.

    You guys utterly, amazingly, supremely ROCK!

    I’m a DreamHost user and have been plagued with this very same problem, which has stumped me for a couple of weeks, because connecting to the database from the shell worked out perfectly. I was (erroneously) assuming that some plugin was malfunctioning under PHP 5.4, and thus the strange database connection error.

    I should have immediately noticed that this error only appears on very old websites, where the database password hasn’t changed in several years… but somehow I missed the ‘connection’ (pun intended). I just thought it was a bad plugin somewhere.

    DreamHost’s control panel, like 1and1’s or Bluehost’s, allows the database password to be changed easily, and after that’s done, the sites work flawlessly under PHP 5.4.

    Woo hoo! Kudos to @ffreundt for getting us a working solution!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Just upgraded to php 5.4 and site doesn't work!’ is closed to new replies.