Support » Plugin: WooCommerce » Just upgraded to 2.2.2 – Shopping cart empty

Viewing 15 replies - 1 through 15 (of 30 total)
  • Roy Ho

    (@splashingpixelscom)

    I have just tested this on your site and it is working fine for me. Try clearing your browser cache and restarting the browser. Then retest.

    Thanks.

    I have already tested this. This only works on Firefox.

    On Safari and Chrome it doesn’t work.

    I run Mac.

    Any suggestions?

    And on iPad and iPhone using Safari it doesn’t work either.

    same here.. older browsers give gart empty as does safari on IOS. Rolling back to 2112 kills all the order history HELP

    Roy Ho

    (@splashingpixelscom)

    Ok is this only happening when you add to cart from category page? And that if you’re in single product page, this does not happen?

    If you first go to single product and add to cart, then cart work. If you first add to cart via category page then cart doesn’t work.

    In first options after you add to cart via single product, then you can also add to cart via category 🙂

    Loks like some bug.

    If you test this two options before delete browser cache.

    Roy Ho

    (@splashingpixelscom)

    Ok I was able to confirm this issue on ajax add to cart. I have already left a note on git about this.

    Yes, when product is added to cart from the product page it works, but when added from a category page or featured products it fails.

    So will it be fixed in next minor release of WC?

    When can we expect this to happen?

    Thanks.

    Workaround:

    I you disable AJAX feature under WC -> Settings -> Products then it adds the product to the cart as it should.

    You can do this as a temporary solution until the AJAX add to cart feature is solved.

    @nikolaj7 thank you for this work around, I’ve been having the same problem and thought I’d fixed it but turned out it was only working in Opera or if you were logged in as administrator.

    Disabling AJAX works in Chrome, Firefox, Opera and iE but not tested it on my phone yet, hope the bug gets sorted soon!

    Same Problem here. Disable AJAX and it works.

    I turned off AJAX, however my cart page (http://soul-esteem.com/store/cart/) continues to try to show a blog page and not the content on the cart page. I would love to hear any suggestions.

    Same issue on all sites updated with 2.2.2

    Is there any way to roll back to 2.2.1 and does that fix the issue as well?
    You know Murphy: got a new webshop that just went live… bad timing!

    Disabled AJAX and tested. It works. Thanks.

    What is the original purpose of “Enable AJAX add to cart buttons on archives”. Do not find any documentation on this setting. Not a developer and hence the question.

    I wish I had read this some 17 hours ago.
    I though some plugins caused it and after much brain-storming and headache, i broke my installation ….
    In trying to resolved this issue, the “tiny” programming spirit in me asked me to delete some unused tables and kaa-boooom..
    i killed my site.
    I am here this morning having to start all over again.
    I am here e tough to give some good news to the image resize issue with WC.
    I did some css tweaks and it’s about the only joy that I wouldn’t have learned this had my site not broken.
    Please be assured it’s okay.
    I have just a single product setup as as the time of this writing and everything os working perfectly.

    my site after the tweak: http://solarpurchases.com/product
    file: http://www.mediafire.com/view/sr285t70ssm37ss/WC_Image_Tweak.css

    http://wordpress.org/support/topic/product-image-center?replies=2#post-6011812

    Include it in your child theme please.

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Just upgraded to 2.2.2 – Shopping cart empty’ is closed to new replies.