Support » Fixing WordPress » Just upgraded, can’t edit posts (pages edit fine).

  • That’s the gist of it up there, in the subject line. I just upgraded to 2.6 and I went to edit the most recent post, but I got an error that read “Fatal error: Call to undefined function: wp_post_revision_title() in /homepages/44/d93886633/htdocs/dan/blog/wp-admin/edit-form-advanced.php on line 10”. I went back and tried to edit other entries, but it doesn’t seem to matter when I posted them, they’re all giving me the error. I tried to edit a page, rather than a post, and that worked as normal.

    –d

Viewing 4 replies - 1 through 4 (of 4 total)
  • Same here.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Fatal error: Call to undefined function

    You did not upload ALL of the WordPress files.

    Reupload WordPress, and get all the files this time.

    I encountered the same problem too. I’ve uploaded ALL of the wordpress files and it still didn’t work. Please advice the next step.

    I had the exact same issue. Even though I’d already uploaded every file for an upgrade, for some reason I had to overwrite one of them to get it working:

    – FTP into your site

    – Navigate to your ‘wp-includes’ folder

    – Re-upload the file ‘post-template.php’ (this is the file that contains the wp_post_revision_title() function)

    – That should fix it.

    I did a full text search and post-template.php was the only file with that function name. Once I re-uploaded it, everything worked fine again.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Just upgraded, can’t edit posts (pages edit fine).’ is closed to new replies.