Support » Plugins » just updated to 3.6

  • Resolved stufa88

    (@stufa88)


    Hi, i just updated to version 3.6. Now when i save posts i get these 3 errors

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/huertosh/public_html/wp-content/plugins/eshop/eshop-product-entry.php on line 341 and defined in /home/huertosh/public_html/wp-includes/wp-db.php on line 992

    Warning: Cannot modify header information – headers already sent by (output started at /home/huertosh/public_html/wp-includes/wp-db.php:992) in /home/huertosh/public_html/wp-admin/post.php on line 222

    Warning: Cannot modify header information – headers already sent by (output started at /home/huertosh/public_html/wp-includes/wp-db.php:992) in /home/huertosh/public_html/wp-includes/pluggable.php on line 875

    Then when i look at page in browser window, the page is there but missing the photos for the post pages. If i reneter the pages and save again, i get the same error but the photos appear. Its not life or death, but it is an irritating waste of time.

    I am not php savvy, how can this be fixed? Heres the site but its as i write with all images displaying http://www.huertoshop.com

    Thanks

    Stuart

Viewing 15 replies - 1 through 15 (of 30 total)
  • esmi

    (@esmi)

    Forum Moderator

    What version of eShop are you using?

    thanks for the quick response.

    an older version, version 2.4… we’ve made loads of updates that if we update the eshop we’ll lose

    esmi

    (@esmi)

    Forum Moderator

    Then you have a problem, I’m afraid. The issues you have are being caused by the fact that you are using an ancient, hacked, version of the plugin. We (as in eShop’s developers) only support the current, unhacked, version of the plugin.

    hmmm, thanks for the awful news. however, as i still seem to be able to maintain my content, despite the irritating error, i guess i have the option of just living with it (at least until it gets worse and worse), right?

    esmi

    (@esmi)

    Forum Moderator

    Right now, I couldn’t even be sure that the plugin will work properly. The plugin is so old that it may stop working completely and/or may pose a security risk for the site as a whole. eShop is now on version 6.3.11

    thanks esmi. i’m back in touch with the guy that did the site, see what we can sort out.

    you’ve been a great help, even if i hate the answer!

    s

    esmi

    (@esmi)

    Forum Moderator

    Sorry I couldn’t be of more help but I do encourage you to keep WordPress and all themes & plugins updated for the best in terms of performance & security. With regard to eShop specifically. Never edit the core plugin. Build add-on plugins for your customisations instead. There is a lot of information on how to implement customisations at http://quirm.net/wiki/eshop/

    i think i’ll have to change the theme to be honest… its not that great anyway. many functions didnt work (e.g cant show original price and sale price, have to type it into text). we’ll see, time and money as always is the prob! thanks again

    esmi

    (@esmi)

    Forum Moderator

    The warnings aren’t coming from the theme. They’re coming from the old copy of eShop. It is simply not fully compatible with the current version of WordPress. Only eShop 6.3.11 is.

    hmmm that changes everything i have:

    eShop for WordPress
    Deactivate | Edit
    The accessible shopping cart for WordPress 3.0 and above.

    Version 16.2.8 | By Rich Pedley | Visit plugin site

    so therefore back to square one. it isnt an old version of the eshop plugin, as far as i can tell its the most up to date. however it isnt 6.3.11 its 16.2.8! and there is no info suggesting i can update it further

    esmi

    (@esmi)

    Forum Moderator

    There isn’t a version 16.2.8 of eShop. The current version is 6.3.11.

    i opened the plugin and this is the first few lines

    <?php
    if (‘eshop.php’ == basename($_SERVER[‘SCRIPT_FILENAME’]))
    die (‘<h2>Direct File Access Prohibited</h2>’);
    if(!defined(‘ESHOP_VERSION’))
    define(‘ESHOP_VERSION’, ‘6.2.8’);
    /*
    Plugin Name: eShop for WordPress
    Plugin URI: http://wordpress.org/extend/plugins/eshop/
    Description: The accessible shopping cart for WordPress 3.0 and above.
    Version: 16.2.8
    Author: Rich Pedley
    Author URI: http://quirm.net/

    esmi

    (@esmi)

    Forum Moderator

    You are still not using the latest version of eShop. And you’ve said yourself that you’ve hacked your copy of the core plugin. So we can no longer predict what issues you may have introduced as a result. We simply do not support old or hacked copes of eShop.

    no, i was confused at the beginning. the theme was changed, not the eshop. that was the theme isnt updated. the eshop i dont think we touched other than text changes to spanish, which is easily redone

    hello – i hope you’re on lunch and havent just walked away. I have established that i do have the eshop verdion for worpress 3.0 and above – and wordpress isnt telling me this is an updated version either – , and i havent changed anything within the plugin (the designer i mentioned previously has only changed the theme, not eshop) but i have these problems still. why?

    please help

    stuart

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘just updated to 3.6’ is closed to new replies.