Support » Plugin: Stackable - Gutenberg Blocks » Just switched to this theme. Why does Easy Google Fonts not work?

  • Resolved Nick Freiling

    (@nickfreiling)


    I just switched to this theme. Love it! That said, Easy Google Fonts doesn’t seem to work. It’s a popular plugin used to change fonts globally. Thing is, everything looks fine when I’m logged in and using Customizer. Then when I visit the site without being logged in, the font switches to some default serif. On my phone, though, it looks just fine. Is this a theme issue or some kind of browser issue?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor gambitph

    (@gambitph)

    Hi @nickfreiling!

    Are you referring to Stackable theme by any chance? I tried what you’ve mentioned about using Easy Google Fonts with our theme and the fonts were working fine and were able to change the content even when I logged out.

    In styling issues like this, what we usually do is to check for caching plugins and performing a clear cache both on the plugin and browsers (this will make the changes to reflect after refresh), checking if the setting didn’t work in a particular content or if the CSS selector needs to be fixed to be overridden.

    I’ve flushed all the caches — still no change.

    The right fonts (from Easy Google Fonts) show up on our blog post pages and a few other pages. I’ve tried multiple browsers and a few computers.

    people.fish/home : fonts don’t work here
    people.fish/blog : font don’t work here
    people.fish/about : font DOES work here
    any blog post pages: font DOES work there

    Very strange! Any other ideas?

    I deactivated Easy Google Fonts because I noticed Rubik was already pre-installed into the Paragraph block. This isn’t the easiest way to apply the same fonts across my website, but I wanted to see if it was a problem with the plug-in.

    Turns out that even when Easy Google Fonts is deactivated, the problem persists. The font looks fine as long as it’s the theme default font, but if I change it from inside a paragraph to any other font besides default, it turns into a serif font. But this happens only on some pages — it seems to be pages where I’m using Stackable blocks (or possibly other plugin blocks, too), because the pages where it’s not occurring are just blog posts with Paragraph, Header and Image blocks.

    Any ideas? Could it be a particular block that’s breaking this?

    I solved the problem. Using the CoBlocks plugin overrides Easy Google Fonts on this theme (and maybe all themes?). I deactivated that plugin, problem solved. The fonts weren’t rendering on pages where I was using a CoBlocks block.

    • This reply was modified 4 months, 1 week ago by  Nick Freiling.
    Plugin Contributor gambitph

    (@gambitph)

    Hey Nick!

    Glad to hear that you fixed your problem. 👍

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.