Support » Alpha/Beta/RC » Just some bugs I’ve noticed

  • 1. This is in BOTH WP15 and WP20. If you have categories (let’s say 25) and you delete every category but the default one, the default one will add all the previous posts together into the main one.

    Here’s what I mean. I have 200 some posts. I went through and deleted 24/25 categories (except default) and when I was done wordpress was reporting that the category had 690 something posts listed. There were only 200 posts so the actual posts werent copied but wordpress was reporting the wrong number. It took the number it new that the category held and when it moved each post to the default category it took the current number and added the number that the deleted category held and combined it with the default category.

    Hope that was clear.

    2. After I moved all posts to the default category I can’t delete any posts. It gave me some big long error (via JS) saying that my SQL syntax was messed up. I am no longer running 2.0 so I cannot copy the errors. Sorry.

    3. Either PHPExec has a problem or WP2 has a problem. I cannot execute PHP inside a post with PHPExec. I have defaulted in making a page with a custom template where I execute the php (the archives).

    RC3 seemed very buggy to me (not to mention that upgrading to it was a royal pain).

    4. If you do a fresh install and then import:

    The comments go bezerk. It was giving me errors in the WP-Admin so I ran upgrade.php but after that I had no comments. Everything was 0. Unfortunately.

    These are the bugs I have found. If I am supossed to report them somewhere else please forward me there.

Viewing 5 replies - 1 through 5 (of 5 total)
  • skippy



    Not all plugins are yet compatible with WordPress 2.0. See this page for an on-going effort to record which are and aren’t.

    Ryan Boren


    WordPress Dev

    For #4, if you put tables from a 1.5 DB over a 2.0 install, all manner of stuff willl break.

    RE: #4 – Since WordPress tracks the database version now, you have to modify the value in your options to get upgrade.php to update your imported tables.

    In other words, in your WP database go into the wp_options table, track down the ‘db_version’ option, and set the value for it to a number previous to the one already there. Then go through the upgrade. This will fix the problem with comment #s you’re seeing.

    My comment counts are wacky since updating to 2.01 and I did go into wp_options table and then ‘db_version’. Is this the number to change:

    option_value 3437 (change to 3436)?

    I went through the update process again and that didn’t solve the problem. I’m using spam karma 2 (updated plugin) and have run thru the other plugins.

    Can’t seem to get this comment count working?

    Sorry don’t mind me lol!

    My comment count before the upgrade was fine, it was the comment counts for the comments made after the upgrade that were wonky (that I could see). I did Kafkaesqui’s solution, problem not solved. After I posted the above I realized it was the comment counts that were made since the first upgrade, but not the Kafkaesqui fix. So I went in and made a comment in the affected blog posts. The comment count jumped up to the correct number.

    I think I’m good to go now :crosses fingers:

    Thanks for the fix (again) Kafkaesqui!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Just some bugs I’ve noticed’ is closed to new replies.