Support » Plugin: Twitter Badge Widget » just sits there loading

  • Resolved kbsamurai


    v 0.8 does show the proper link to the twitter page but just sits there spinning with the word “loading” and never actually loads any posts. Even setting the number of posts to 0 in the widget doesn’t stop it from getting hung up on the page.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Workshopshed


    Hi kbsamurai, sounds like the plugin is writing the widget but the javascript that populates the tweets is timing out or erroring on your page. The loading will stay there till the rest of the page is displayed as the javascript will run on a document complete.

    Is it possible to have a look at your site?

    What other plugins are you using? It might be that there’s a Jquery compatibility issue I need to check out.

    I’ve just tried setting the tweets to zero, and can confirm that this will default it back to 1 when it’s displayed but I should really stop it saving that.



    possibly, though I’ve moved on to another plugin that did work, so yours is no longer activated.

    active plugins at the time I was trying out your plug-in were
    Contact Form 7
    FB List Connect
    FV Simpler SEO
    Google +1
    Google XML Sitemaps
    Really Simple CAPTCHA
    Wapple Architect

    Plugin Author Workshopshed


    Thanks for the additional info, looks like you’ve got a suitable replacement for your site.

    Does not seem to be Google +1 or Contact Form 7 and I know it’s not Google XML Sitemaps as I’ve got that on my site.

    There’s some complex stuff going on with your site theme with carosels and popup windows on that site so it’s possible they are interfering somehow.

    I’ve added some stuff into the next version that should help with compatibility issue.

    Thanks again for testing.

    Plugin Author Workshopshed


    I’ve applied the no conflict techniques to the 0.9 version and have made some changes that will made diagnosit issues for others simpler.

    I didn’t want to start a new thread since I have the same problem. I figured out it’s a conflict with the Events Calendar plugin below. Any idea how to fix it? When I enable the Events Calendar plugin twitter plugin just says loading. If I inactivate the calendar plugin, then the twitter plugin works.

    Any help would be appreciated.


    Plugin Author Workshopshed


    Hi Fred, give me a couple of days as I’m out of town. I will load that events plugin on my test site and see how its interacting. Might be something I can fix or I might need to colaborate with the Events developer

    Plugin Author Workshopshed


    I’ve tried it with Events calendar on my test site and it works both for calendar mode and for event list mode. I also tried loading it either before or after the twitter widget and it’s still working fine for me.

    Looking at the following link “handling errors in jquery document ready I see that an error in another script would stop all subsequent ready events being fired so it’s possible that’s happening with one of the other scripts on your site. Are there any errors reported by your browser?

    As an aside, whilst checking this, I did spot that the “Thickbox” which is installed as part of wordpress is using the same “TB” prefix in it’s javascript and css as I’ve got in the Twitter Badge. So I’ve swapped it to be “TBW” in the Twitter Badge Widget code.

    Plugin Author Workshopshed


    There’s an experimental version 1.3 at

    This does not rely on the ready event so should load even if there are other issues with other plugins.

    I’ve not tested the layout after making changes to the CSS. If you want to give it a go and let me know if it fixes the issue or if there are layout issues. If the latter let me know what theme you are using.

    I deleted the old plugin and installed the experimental version. It works fine now. At first glance, I can’t really see anything that doesn’t seem to be working with the other plugins or theme I have installed. If something comes up I’ll post here.

    Thanks for all the help.

    Plugin Author Workshopshed


    That’s great news. I’ll release the experimental version once done a little more testing

    Plugin Contributor 2020media


    Did you release the experimental version? Would be good to close off this thread if it’s all working now.

    Plugin Author Workshopshed


    Yes, the experimental version was superceeded with version 1.4, see changelog here.

    I’ve set the thread to resolved but I don’t know how to set it to closed.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘just sits there loading’ is closed to new replies.