Support » Plugin: Stop Spammers Security | Block Spam Users, Comments, Forms » Just performed update and getting errors all over

  • Resolved Peter La Fond

    (@myinternetscout)


    Hi support,

    I updated the Stop Spammer plugin and now have errors in the header on almost every page, on front end and backend.

    Error says…

    “Warning: Cannot modify header information – headers already sent by (output started at /home/myintsct/public_html/wp-content/plugins/stop-spammer-registrations-plugin/includes/stop-spam-utils.php:336) in /home/myintsct/public_html/wp-includes/functions.php on line 6029”

    I had to turn on off the plugin. Please help me remedy this.

    Thank you, Peter

Viewing 11 replies - 1 through 11 (of 11 total)
  • Thread Starter Peter La Fond

    (@myinternetscout)

    Okay, I deleted the plugin and I’m still seeing errors on certain pages. How do I correct this??

    Here’s an image of an error message seen in the Jetpack module on the admin dashboard. This error is shown even after the plugin is deleted.
    https://i.imgur.com/orURQA7.png

    • This reply was modified 2 years, 9 months ago by Peter La Fond.

    also encountered errors after updating the plugin to version 2020.1
    error in firefox: “content decoding error”
    error in safari: “cannot decode raw data”
    could not access wp-admin anymore so using ftp renamed the plugin to ***_old, which gave me access to wp-admin again
    Then restored from recent backup.

    ***NOTE:
    in the plugin’s description I read:
    “If you update to version 2020, please clear your cache to see the new UI.”
    would that solve the problem? clearing the cache before updating?

    • This reply was modified 2 years, 9 months ago by breinmark.

    I just had the same issue. Had to disable the plugin in order to get back to working.

    Same error here. Have to deactivate it until it is fixed. When reactivating it it gives also a warning “The plugin generated 2 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.”
    Please fix it 😀 Thank you…

    Plugin Author Trumani

    (@trumani)

    Hi everyone, thank you so much for reporting. A last minute change to add a notice to clear the browser cache upon updating looks like it broke things. I believe I have a fix. Please also ensure to clear your browser cache when you update to 2020.3. I apologize that I did not catch this in my testing. I am more inexperienced with versioning, and I promise that will change. This is not a great way to meet the people who use this plugin, but please email me at any time at ryan@trumani.com. I took on this project because I believe so strongly how this was built, and I will do better when I make updates in the future.

    Kind regards,

    Ryan

    Thanks for the quick response! Really appreciate the transparency.

    Plugin Author Trumani

    (@trumani)

    Absolutely, and thank you for you patience with me. Oh, re-reading my post, I meant to say version 2020.1.3 is now the master.

    Working fine now. Thank you for the quick fix. Have a great weekend…

    Thread Starter Peter La Fond

    (@myinternetscout)

    @trumani thank you for all the help on this! With the latest update, the header error issue is resolved. However, I see broken images when I go to the Stop Spammers options page. (see screen shot: https://i.imgur.com/pTAxbZH.png )

    Peter

    @trumani many thanks for fixing this so quickly!

    Plugin Author Trumani

    (@trumani)

    Thanks for the feedback, everyone! Peter, I apologize, I am not sure why you see some, but not all images. Would I be able to take the driver’s seat? You can reach me directly by emailing ryan@trumani.com.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Just performed update and getting errors all over’ is closed to new replies.