Support » Multisite » [Resolved] Just installed Multisite but no SuperAdmin

[Resolved] Just installed Multisite but no SuperAdmin

  • I have just installed multisite onto http://jobs4thais.com and everything went smoothly but nothing has shown up in the dashboard, there is no super admin panel or anything and nothing to select sites or add new sites. Does anyone have any ideas?

    Any help is much appreciated.

Viewing 15 replies - 1 through 15 (of 31 total)
  • Moderator Jan Dembowski


    It could be you’re just missing it:


    Or an easy way to check if you’ve installed it correctly is to visit your network dashboard URL.


    You’ll either get the network admin panel or a message explaining why you didn’t.

    It says:

    You do not have sufficient permissions to access this page.

    Do you have any idea what this means?

    Thanks in advance.

    Moderator Jan Dembowski


    Most likely it means you didn’t install multisite correctly. 😉

    Looking at that site, there is no existing content right? If so then you can skip the part where I say “Make sure you back up your files and database first.”

    If you are not starting from scratch and have content to lose, do make those backups.

    How far did you get in the installation steps? Does your wp-config.php file contain this line?

    define('WP_ALLOW_MULTISITE', true);

    That line has to be above where it says /* That's all, stop editing! Happy blogging. */

    Once that’s done the rest of the configuration should be possible.

    I have content but it is backed up.

    I have added that line but it was below the line of text, but it let me carry on with the installation?

    I have changed the line of code to be above that one but still cannot see anything.

    Also when i go to Network Setup it says – Warning: An existing WordPress network was detected.

    Moderator Jan Dembowski


    That’s probably a good sign but I’m almost out of ideas.

    On my Crash Test installation, when I visit


    I get "The original configuration steps are shown here for reference." and it shows me what I had to change to make it work.

    Try visiting that URL on your installation and confirm that the changes it says are actually made to your file system (for blogs.dir) and your .htaccess and wp-config.php files.

    If you get into trouble and aren’t sure where or what you did, then restore both the files and database backups from just before you attempted this.

    That will put you back at the beginning and let you try again new.

    It just says the same thing

    You do not have sufficient permissions to access this page.

    It says on the netowrk.php page ‘To create a new network, you will need to empty or remove the network database tables.’

    Where would I need to got to remove these table?

    Moderator Jan Dembowski


    Now we’re getting into the deep end of the pool and definitely should consider swimming safety.

    If you are familiar with phpMyAdmin or mysql command line, then dropping the new tables is not a big deal.

    But walking someone through that is really risky and it’s easy to make a mistake that breaks things.

    Make sure you have good database backups as well as file backups.


    Seriously, make sure you can restore your database backup as well as your files.

    If you feel confident then you can drop the tables that use your table_prefix and _1_. So if you are using the default prefix it would be tables that has names like so


    If the error message is correct then dropping those may solve the problem.

    If the Really Bad Thing™ happens then restore your backup and start from the beginning.

    OK, I used BackupBuddy to save everything so should be fine.

    Do I just go into phpMyAdmin and remove the files named above?

    Moderator Jan Dembowski


    OK, I used BackupBuddy to save everything so should be fine.

    Not to be overly direct but please make sure you can restore your backup even if you don’t have access to BackupBuddy.

    Proceed at your own risk! You could lose everything on your WordPress installation if you make a mistake!

    There, that’s out of the way. 🙂

    That said, go into phpMyAdmin and locate the tables (they’re not files) like I described. Select those _1_ tables and use the option to drop them.

    I don’t use phpMyAdmin (I’m more of a CLI person myself) so I can’t provide you specifics on how to do that. Read up on phpMyAdmin and give it a go if you feel comfortable with it.

    And once again, if the Really Bad Thing™ happens then restore your backup and start from the beginning.

    I’ve had a look through and can’t see any tables that have the same names as _1_.

    I’m at a loss sorry!

    Moderator Jan Dembowski


    Well, then the only advice I have is

    – Take a break. Working on something that’s not making sense to you can drive you nuts.

    – Read up on how to restore your database/file backup.


    I think you made a misstep early on in the instructions and now your WordPress installation is in a confused state regarding the multisite network.

    There is probably a simple way to resolve it but as you are discovering, multisite is a little more complicated than regular WordPress. By “easy way” I really mean “easy if you know how to do it…”

    If you can put it all back the way it was prior to attempting this then you can redo it correctly the second time around.

    The wp_1_ thing is a misleading ‘error’ that doesn’t actually mean what you think it does.

    What;s your blog prefix?

    Sorry I don’t know where to find the prefix?

    Moderator Jan Dembowski


    Look in your wp-config.php file for the line that says

    $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!

    The default value for $table_prefix is ‘wp_’ but it could be changed in your installation.

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] Just installed Multisite but no SuperAdmin’ is closed to new replies.