Support » Plugins and Hacks » [Resolved] Just an idea..

[Resolved] Just an idea..

  • My Dev server shows me every troubles even PHP Notices in the page. My Prod server of course not.
    Could you modify your plugin to avoid notices with $_POST variables ?
    I mean regarding to the settings, notices may be displayed.
    For instance:
    My plugin is configured to NOT ask for an image/logo, but after submitting a notice is displayed: Notice: Undefined index: website_image in (…)\plugins\ultimate-blogroll\domain\UbPage.php on line 120
    Same thing for this, if i don’t want any backlink:
    Notice: Use of undefined constant website_backlink – assumed ‘website_backlink’ in ultimate-blogroll\persistence\UbLinkpartnerMapper.php on line 169

    Do you see what i mean ? there are other notices but i need to understand your code.
    Best regards


Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author jensg


    Sure, you are right, you should never surpress notices. I will fix this, I should start with writing unit tests. Thanks for taking your time and marking this, it is all legacy code, I know better now but I haven’t had any time to take a clear look at it as you do. Keep up the good work!

    Plugin Author jensg


    Do you have any contact info? skype? mail? …?
    Our communication will be much better, I really appreciate you taking your time for this.
    I will add entity classes and move my business logic into there, that way the validation is always ensured.

    Plugin Author jensg


    The plugin is updated to version 2.5 I have removed all the @$_post’s it is fixed but I am working on a better fix with entities. I know it also occurs with the gui array but I can’t simply move that one out. I will do it in another version. Thanks for reporting

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Just an idea..’ is closed to new replies.