WordPress.org

Forums

WP Super Cache
Just a few notices (non critical) (7 posts)

  1. MattV
    Member
    Posted 1 year ago #

    I just installed and configured WP Super Cache 3.4 on a fresh multisite install (with subdirectories) and everything works fine: pages are cached using mod_rewrite.

    I do see a few notices and warnings when wp_debug is set to true but they don´t seem to prevent the plugin from working. I´ll list them anyway, in case you´re interested:

    Notice: Undefined variable: base in /home/user/domains/mydomain.com/public_html/wp-content/plugins/wp-super-cache/wp-cache-base.php on line 24
    Notice: Undefined variable: base in /home/user/domains/mydomain.com/public_html/wp-content/plugins/wp-super-cache/wp-cache-base.php on line 27

    Warning: Cannot modify header information - headers already sent by (output started at /home/user/domains/mydomain.com/public_html/wp-content/plugins/wp-super-cache/wp-cache-base.php:24) in /home/user/domains/mydomain.com/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 91

    Notice: Undefined variable: disable_supercache_htaccess_warning in /home/user/domains/mydomain.com/public_html/wp-content/plugins/wp-super-cache/wp-super-cache/wp-cache.php on line 371

    (FYI the constants in wp_config are set and accurate)

    Thanks for this great plugin!

    http://wordpress.org/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks Matt. Do you have WordPress installed in folders with multisite enabled? I've fixed those warnings. The development version will update in the next twenty minutes if you want to try that!

    http://ocaoimh.ie/the-development-version-of-wp-super-cache/

  3. MattV
    Member
    Posted 1 year ago #

    Great! WordPress is installed in my root directory and each site in the network has its own (virtual) directory, like this:

    - mywebsite.com
    - mywebsite.com/english/
    - mywebsite.com/french/
    - mywebsite.com/spanish/

    (Each language is a separate site in the network)

  4. bigdrobek
    Member
    Posted 1 year ago #

    Hi
    I have same error.
    Please what I should do?

    WPMU subfolder instalation, last version.
    Thank you
    Radek

  5. acescence
    Member
    Posted 11 months ago #

    These warnings still exist in the current version.

  6. Odolyte
    Member
    Posted 10 months ago #

    Same for me i still have these warnings with WP multi sites.

  7. DenverEric
    Member
    Posted 10 months ago #

    I'm getting this one on a fresh install of WP Cache (not multi site)

    Notice: Undefined variable: disable_supercache_htaccess_warning in /home/user/domains/mydomain.com/public_html/wp-content/plugins/wp-super-cache/wp-super-cache/wp-cache.php on line 371

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.