Support » Plugin: Clearfy – WordPress optimization plugin and disable ultimate tweaker » Just a couple of bugs/incompatibilities

  • Resolved catmaniax

    (@catmaniax)


    Hello!

    1. I use the plugin “Disable All WordPress Updates” (https://wordpress.org/plugins/disable-wordpress-updates/#description) and I activate/deactivate each time I want to check if there any updates. So, when I activate it, the hidden admin notices of Clearfy disappear from the right side of the admin bar.

    2. I also use an optin plugin called DeliPress (https://wordpress.org/plugins/delipress/) and for some reason, when I select the option “Only Selected” on Clearfy’s Hide Admin Notices, I get this error:

    Fatal error: Uncaught ArgumentCountError: Too few arguments to function Delipress\WordPress\Admin\Setup::setupWizard(), 0 passed in .../wp-content/plugins/clearfy/components/disable-admin-notices/includes/classes/class.configurate-notices.php on line 202 and exactly 1 expected in .../wp-content/plugins/delipress/src/Delipress/WordPress/Admin/Setup.php:53 Stack trace: #0 .../wp-content/plugins/clearfy/components/disable-admin-notices/includes/classes/class.configurate-notices.php(202): Delipress\WordPress\Admin\Setup->setupWizard() #1 .../wp-includes/class-wp-hook.php(286): WbcrHan_ConfigHideNotices->catchNotices('') #2 .../wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(Array, Array) #3 .../wp-includes/plugin.php(453): WP_Hook->do_action(Array) #4 .../wp-admin/admin-header.php(125): do_action('admin_print_scr... in .../wp-content/plugins/delipress/src/Delipress/WordPress/Admin/Setup.php on line 53

    I already pressed the Reset hidden notices button in case it fixed anything, but no luck.

    The important thing to stress is that this error just appeared today, as soon as my host upgraded my site’s PHP version from 5.6.34 to 7.1.14.

    Please let me know.
    Thanks!

Viewing 15 replies - 1 through 15 (of 19 total)
  • 1. Yes, I checked and the issue is present. Thanks for the help! We’ll fix it in the nearest update.
    So why do you use Disable All WordPress Updates? Clearfy has its’ oun disable updates options and soon we’ll add disable for each theme saparately.

    2. I checked your issue. The conflict observed in PHP 7.1 only. We’ll see what can we do for the compatibility.
    Ask your hosting provider temporary turn on PHP 7.0 if it possible.

    Immodest question: how many plugins on your website?

    1. I know Clearfy has a similar feature to disable all WordPress updates and I’ve tested it since I first installed it, in hope I could get rid of the other plugin since it would be a duplicate functionality, but the “Disable All WordPress Updates” plugin seems to work better for that part.

    And I say this because refreshing the plugins page (…/wp-admin/plugins.php) with that plugin active, is blazing fast since it does not allow communication with the repository or anywhere else, so the page gets reloaded in an instant.
    That was not the case with Cleafy’s similar options unfortunately. Maybe you can test it out in a local test site with many plugins installed and see what I’m talking about.

    2. I was waiting for a long time to get upgraded to the new PHP, so downgrading is not an option. The speed difference between those two versions of PHP is significant!

    I currently run about 60 plugins, which were selected very carefully and tested for some time, many of which will be removed or replaced, since I’m still testing things out.

    From my experience, the number of plugins installed/active has no negative impact on anything, maybe only conflicts in some cases.
    You may have 100 plugins running with a page load of 2 seconds or only 2 plugins and your site is bottlenecked because they are poorly written.

    So for me it’s the quality that matters, not the quantity 🙂

    1. Some time ago there was an issue with disable commercial plugins’ updates. With the last update we fixed it. How long ago did you tried our disable update option? Can you please try again.

    2. We’ll check the compatibility.

    Hey, I tried it with the latest current version as well.

    Ok, we’ll check this.

    Thanks, please reply here if you have any news 🙂

    Delipress fixed. Wait in Clearfy 1.2

    Thanks 🙂

    Is the update coming these days?

    Cooking and testing. Wait a bit.

    Disable All WordPress Updates fixed too.

    That’s great news 🙂

    Wait for update in some days, maybe even today or tomorrow.

    I will, thanks!

    Hey!

    First of all, thanks for the latest update, it’s great and resolved past issues 😀

    I found a small conflict with another plugin called Analytify that I use (https://wordpress.org/plugins/wp-analytify/) that breaks Clearfy’s CSS.

    This is what happens inside Clearfy’s options, when that plugin is active:

    https://s18.postimg.org/q7chl624p/clearfy1.png

    Instead of this:

    https://s18.postimg.org/vvisc2e6x/clearfy2.png

    I will post it on their support forum as well.

    I’m waiting for your feedback on this 🙂

    Hey, Analytify’s author released an update on his plugin that fixed the issue above 🙂

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Just a couple of bugs/incompatibilities’ is closed to new replies.