Support » Theme: Athena » Jumbatron not working in Athena theme

  • Hi,
    I have the athena theme for my website,(it was recommended in the book I was using & I liked the look) A week ago I did an update and the jumbatron stopped working – just doesn’t come up at all, there’s nothing in the back end that I can see to tell me why it isn’t coming up – but I have no idea how to look at the coding – I’m a total duffer when it comes to anything with computers)
    I have now paid for the athena pro to see if I can get help, but nothing is happening there. I can’t find a way to talk to anyone other than opening a ticket & quite frankly it all looks dead. Have I paid money out for nothing? Are Smartcat still working?
    I can’t find any way to email Smartcat at all.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 29 total)
  • Hi, try to do this. It worked for me.

    1) Open a ftp connection with your site and look for this file:
    /your site/wp-content/themes/Athena-Pro-1.0.6/inc/js/camera.js

    2) download the file camera.js via ftp

    3) open file with any code editor. Notepad is fine too but I recommend a programmer editor, for example notepad ++. Then Find the line numbered 751. The line should look like this: $(‘.camera_stop’,camera_thumbs_wrap).live (‘click’,function(){ …

    4) Comment out the code from line 751 through line 781. Then Upload the file again and replace the old one

    Empty browser cache with ctrl+F5 and refresh page. You should be able to fix the problem. I hope to be proved helpful. Good luck!

    Hi DebtheDyer,

    I noticed your site is running. I’m wondering what process you followed.

    To Manekineko70…I’m not comfortable digging into code and besides, I payed Smartcat Digital for two licenses and expected them to maintain updates and customer service.

    From what I can find it’s possible the company has ceased to exist. I can’t find them on facebook or linkedin.

    Something tells me it’s time to find a new theme. :/

    fotomatt in colorado

    Confirming that @manekineko70’s suggestion fixed this issue for me.

    Thread Starter debthedyer

    (@debthedyer)

    Hi Guys, thanks for the helpful suggestions _ I actually found some other discussions on the same topic after putting my comment earlier – you can always guarantee you find something after …

    There was a recommendation to add a plugin for now called “Enable jQuery Migrate Helper” which I did and the jumbatron is now working… not sure how long I can use this for, but at least it buys some time!

    I am very concerned by the fact that I have paid out money for a theme because by doing so I should have got support for the theme – and nothing has happened. Smartcat are completely ignoring everything. There is no method of emailing them, nothing.

    I hope that wordpress will take this on board. Not sure if I can get my money back and go back to the free theme now. Pretty disgusted really!

    Ugh…I just discovered that (in addition to this issue) NONE of my photography galleries are working. As a photographer that’s kind of key…ya know…

    I think it’s time to abandon Athena and especially SmartCat Design…especially since it seems the company no longer exists.

    fotomatt in colorado

    Hello all: the recommendation to add “Enable jQuery Migrate Helper” worked fine. The Jumbotron is back at least. So far so good. Thanks for the tip!

    The plugin “Enable JQuery Migrate Helper” works like a charm. SmartCat is not a ghost company. They can be found at: http://www.smartcatdesign.net

    they seem to be indeed a ghost company, a out of date website doesn’t make a company. the only thing that seems to be working is their payment portal. I have been tracking down the employees one by one and they have so far all moved on, one got quite angry that I contacted him even though he listed himself as employed by smartcat on LinkedIn. I’ll post more information if I can track anything down

    I have two websites running Athena – one is the free version and one is the Pro. With the WordPress update, both of these had their jombotron knocked out. “Enable JQuery Migrate Helper” word a treat for both sites. However, as of the updates yesterday, it is back to how it was – no jumbotron and just that annoying spinning thing. Hoping for another update somewhere to sort out the sort out!

    I tried the commenting out but it has not worked for either of these versions. Thank you so much, though, for the suggestions above.

    Update – something that worked for my Athena Pro but not the free version was this plugin….

    Version Control for jQuery

    You enable it, then go to settings to find it and then work your way through the list, rolling back the version until you hit one that works.

    @manekineko70

    Your patch worked for me!

    However on one Athena site some of the featured images won’t show until I scroll down a little bit. Ctrl F5 does load the page o.k., but after some page switches the same issue occurs again.

    Strange thing is that this doesn’t happen on other Athena based sites.

    Any idea?

    Thanks.

    Confirming that installing the plugin “Enable JQuery Migrate Helper” worked to solve this issue for me as well.

    Thank you for the help!!

    I had the migrate helper installed and it was working. As of today it is not working. Haven’t had a chance to dig into this further…but…the end of this theme is still at hand. :/

    The reason this is causing problems is the .live method.
    Apparently the developer stopped updating this camera.js plugin around 2014.

    There are 4 instances of .live on lines 727, 732, 751, & 767 in the file /wp-content/themes/athena/inc/js/camera.js

    The .live method was deprecated and removed from jQuery as of version 1.9.

    The simple fix for all 4 of these methods is to change the .live method to the .on method, like so:
    727 // fakeHover.live(‘vmouseover’,function(){
    change to: fakeHover.on(‘vmouseover’,function(){

    732 // fakeHover.live(‘vmouseout’,function(){
    change to: fakeHover.on(‘vmouseout’,function(){

    751 // $(‘.camera_stop’,camera_thumbs_wrap).live(‘click’,function(){
    change to: $(‘.camera_stop’,camera_thumbs_wrap).on(‘click’,function(){

    767 // $(‘.camera_play’,camera_thumbs_wrap).live(‘click’,function(){
    change to: $(‘.camera_play’,camera_thumbs_wrap).on(‘click’,function(){

    In addition, to maintain the fix, create a child theme, copy the camera.js file to the child theme (perhaps duplicate the directory structure of the Athena theme), then add this code to the child theme’s functions.php file:

    function athena_replace_scripts() {
    // Dequeue & Deregister the original camera.js file
    wp_dequeue_script( ‘athena-camera’ );
    wp_deregister_script( ‘athena-camera’ );

    // Enqueue the fixed camera.js file
    wp_enqueue_script(‘athena-fix-camera’, get_stylesheet_directory_uri() . ‘/inc/js/camera.js’, array(‘jquery’), ATHENA_VERSION, true);
    }
    // add the action to execute the code with a priority of 11 – this ensures that the action will execute after the main theme’s queue.
    add_action(‘wp_enqueue_scripts’, ‘athena_replace_scripts’, 11);

    This code fragment assumes the camera.js file is located in a sub-directory of the child theme – /inc/js/ (similar directory structure of the Athena main theme, but could be placed anywhere in the child theme’s directory).

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Jumbatron not working in Athena theme’ is closed to new replies.