Support » Plugin: Plugin Organizer » JSS/CS Conflict

  • Resolved Pramathesh

    (@paramathesh)


    Hi,

    Plugin works like a charm on all the pages except when in Cart/Checkout where it just shows the first shipping and payment option available while hiding the options otherwise available, I’m assuming it’s some CSS/JS conflict. I have tried disabling Plugin Organizer on these pages but it still wouldn’t work, I’m not sure if I did that properly or not. Is there a work around? Right now disabling the plugin entirely is the only way out of this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    I need a lot more detail than that before I can help you solve the problem. What shopping cart plugin are you using? Did you disable that plugin anywhere on your site? When on the checkout page are you getting any errors in your browsers console? 404? Javascript errors?

    Hey apologies for the delayed response. I never got an email from WP. Nonetheless, I am using WooCommerce for the store. I’m getting the following error with the plugin installed on Checkout

    TypeError: r.order_data is undefined
    [Learn More]
    stripe-payment-request.min.js:1:4699
    Error: The selector you specified (#stripe-card-element) applies to no DOM elements that are currently on the page.
    Make sure the element exists on the page before calling mount().
    v3:1:9820
    TypeError: r.order_data is undefined
    [Learn More]
    stripe-payment-request.min.js:1:4699

    This doesn’t happen when I have the plugin disabled though

    Plugin Author Jeff Sterup

    (@foomagoo)

    First step you should take is to enable all plugins on the cart/checkout page and see if the error goes away. If it does then you have disabled something that is needed on your checkout page. I have enabled stripe gateway on my test site and am having no issues. Did you disable Woocommerce or Stripe Gateway anywhere on your site? I tried disabling Stripe globally and then enabling it on the checkout/cart page and the root url of my site and had no issues. If I disable it globally and don’t enable it on the root url of my site it won’t work. Same for the cart/checkout page.

    I fixed this one by enabling all the plugins on the home page.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.