Support » Plugin: Google Maps Plugin by Intergeo » JSON style does not working?

  • Resolved dominmax

    (@dominmax)


    Hi, I am trying to use Custom Map Styles option with no success.
    (By the way – the url over the help instruction to the Styled Map Wizzard go to 404.)
    I used current map style wizzard.
    However it does not work.
    My style is:

    [
      {
        "featureType": "administrative",
        "elementType": "labels.text.fill",
        "stylers": [
          {
            "color": "#222222"
          },
          {
            "weight": "1"
          }
        ]
      },
      {
        "featureType": "landscape",
        "stylers": [
          {
            "color": "#ffffff"
          }
        ]
      },
      {
        "featureType": "landscape",
        "elementType": "geometry.stroke",
        "stylers": [
          {
            "color": "#dddddd"
          }
        ]
      },
      {
        "featureType": "poi",
        "stylers": [
          {
            "visibility": "off"
          }
        ]
      },
      {
        "featureType": "poi.attraction",
        "stylers": [
          {
            "hue": "#ff0000"
          },
          {
            "saturation": "-100"
          },
          {
            "lightness": "0"
          },
          {
            "gamma": "3.00"
          },
          {
            "visibility": "simplified"
          }
        ]
      },
      {
        "featureType": "poi.business",
        "stylers": [
          {
            "hue": "#ff0000"
          },
          {
            "saturation": "-100"
          },
          {
            "lightness": "0"
          },
          {
            "gamma": "3.00"
          },
          {
            "visibility": "simplified"
          }
        ]
      },
      {
        "featureType": "road",
        "stylers": [
          {
            "color": "#999999"
          }
        ]
      },
      {
        "featureType": "road",
        "elementType": "labels.text.stroke",
        "stylers": [
          {
            "color": "#ffffff"
          }
        ]
      },
      {
        "featureType": "transit",
        "stylers": [
          {
            "visibility": "off"
          }
        ]
      },
      {
        "featureType": "water",
        "stylers": [
          {
            "color": "#b3c8fb"
          },
          {
            "lightness": "50"
          },
          {
            "gamma": "1"
          },
          {
            "visibility": "on"
          }
        ]
      }
    ]

    API key is ok. No errors in console etc…
    Should I do something else to make it work?

    Thanks in advance for help.

    Best for you.
    Dominik

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘JSON style does not working?’ is closed to new replies.