• I run a multilingual site with 3 languages using Polylang plugin.

    Maps(layer) will show in a custom front-page with home_url https://…/language/

    I understand Leaflet Maps Marker loads the Google scripts needed for display google maps.

    Whereas 2 languages properly use <script type=’text/javascript’ src=’https://www.google.com/jsapi?key&ver=3.7′></script>,

    the third language uses http: instead of https: and results in mixed content even though the same layer is assigned to different languages.

    How should I correct this?

    https://wordpress.org/plugins/leaflet-maps-marker/

Viewing 1 replies (of 1 total)
  • Plugin Author RobertHarm

    (@harmr)

    Hi maronus,
    the Google script are loaded via https by default with one exception: if the Chinese locale zn is used, http is used instead. This is due to the fact that users reported issues with https loading in China. Loading scripts depending on locale used was the best workaround I could offer here. Anyway from a feature point of view, loading the scripts via http should not cause any issues – maps will work in the same way as if scripts were loaded via https
    best, Robert

Viewing 1 replies (of 1 total)
  • The topic ‘jsapi mixed content’ is closed to new replies.