Support » Plugin: W3 Total Cache » JS-Minify 404 on NGINX+PHP-fpm

  • Resolved eddie

    (@ediet)


    Hello!

    Server uses NGINX+PHP-fpm

    Everything is great in the plugin, except for the minification of styles and scripts. They give 404 error files upon activation. It doesn’t matter what minification / combination mode… Basically, I tried all the checkboxes.

    Http2 push notifications work out normally.

    On the servers NGINX+Apache everything is always great.
    As I understand it, something is being written to the file .htaccess by default. But what and where should I register for NGINX+PHP-fpm?

    Thank you in advance for your response!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @ediet

    I am sorry about the issue you are experiencing and I am happy to assist you with this.
    In the Performance>Install tab you can see the Rewrite rules based on your settings that should be in the nginx.conf.
    You should check if those rules are applied in your nginx.conf and if not, try adding them manually. Make sure that the Rewrite URL structure is enabled in Performance>Minify.
    Let me know if this helps.
    Thanks!

    Thread Starter eddie

    (@ediet)

    Rewrite URL structure is enabled.

    The rules for rewriting NGINX should be automatically rewritten in nginx.conf if i reboot NGINX?

    • This reply was modified 12 months ago by eddie.
    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @ediet

    Thanks for the feedback.
    Yes, sometimes the rules will be applied once the nginx server is restarted.
    If however, you are still experiencing the issue, make sure that the rules are actually there and check if the /wp-content/cache/minify/ folder is created.
    Thanks!

    Thread Starter eddie

    (@ediet)

    Thanks for the answer!
    It worked after handwriting:

    In the Performance>Install tab you can see the Rewrite rules based on your settings that should be in the nginx.conf.

    And restart.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @ediet

    Thank you for the information.
    Glad I was able to assist and that the issue is resolved.
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘JS-Minify 404 on NGINX+PHP-fpm’ is closed to new replies.