Support » Plugin: WP Speed of Light » JS minification and Mozilla Firefox don’t work

  • Resolved Hans

    (@hvl)


    When I switch on JS minification and look at my website the pictures stay blank in a Mozilla Firefox browser. With MS Edge or Google Chrome it works fine.
    If I switch JS minification off again they show up again…

    No other problems till now.

    Regards,

    Hans.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author JoomUnited

    (@joomunited)

    Hi,

    Can we have the URL of your website? to see where it crash.
    I can’t reproduce that on my side.

    Cheers,

    http://testing.haarlemmarkt.nl

    It also doesn’t support mobile templates enough. When you put on caching and the first visitor is a mobile visitor then all desktop users get the mobile version only, not the desktop version.

    P.S. Template is newspaper by TagDiv.

    Regards,

    Hans.

    Plugin Author JoomUnited

    (@joomunited)

    Hi,

    I think this is something that is related to the theme. Could you please register a free account on our website and create a ticket support (mentioning this post).

    Cheers,

    Thank you. Ticked created.

    (I would like to see the plugin working bacause it is the only plugin that can give my site a score of 85 on google’s pagespeed if all options work. So i am very very happy with it 🙂 )

    Regards,

    Hans.

    Plugin Author JoomUnited

    (@joomunited)

    Oh thanks! we’ll fix that and some new stuff are coming!

    Cheers,

    Could you please post the solution here? I´m having issues with JS minify on several pages – it breaks the famous LayerSlider that´s included in many themes, the WP Cookie Banner (important for legal reasons) and other JS. So it would be important JS minify works fine.

    Thanks a lot!

    • This reply was modified 2 years, 8 months ago by  dlx.
    Plugin Author JoomUnited

    (@joomunited)

    Hi,

    Currently the “minification” setting does minify + group some of the the JS/CSS/HTML files, we will add some new feature very shortly to handle that. In the next version you’ll be able to minify OR/AND group files from the configuration. Usually it’s the file group that is causing those errors.

    The minification error is caused by a syntax error in one of your JS file.

    Though, your website performance should be very correct even without this setting 😉

    Cheers,

    A setting to choose minify OR/AND grouping would be perfect (hopefully separate settings for JS and CSS). Thumbs up!

    And yes, you are right: Performance is already very correct – but bigger (faster) is better… 😉

    Plugin Author JoomUnited

    (@joomunited)

    A setting to choose minify OR/AND grouping would be perfect (hopefully separate settings for JS and CSS). Thumbs up!

    Exactly what’s coming (next week).

    And yes, you are right: Performance is already very correct – but bigger (faster) is better… 😉

    Ah ah ah, yes you’re damn right!

    Cheers,

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘JS minification and Mozilla Firefox don’t work’ is closed to new replies.