Support » Plugin: Campaign Monitor Forms by Optin Cat » JS issues with 1.5.0

  • Resolved yodathedark

    (@yodathedark)


    Updated to 1.5.0 this morning and the optin form stopped working. Examining the console revealed that submitting the form was bringing up a “Uncaught ReferenceError: fca_eoi is not defined” error.

    Obviously, the fact this makes the form unusable also makes this version of the plugin unusable and I’ve reverted to 1.4.2 for the moment.

    https://wordpress.org/plugins/campaign-monitor-wp/

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m getting the same javascript error with the AWeber Forms by Optin Cat plugin Version 1.5.0. The error message is referencing line 68 of script.js in the assets folder:
    fca_eoi.invalid_email = $this.find('.fca_eoi_error_texts_email').val();

    Same thing I found.

    Plugin Author Ryan Novotny

    (@ryannovotny)

    Hi guys,

    I’m the Lead Developer of Optin Cat, and found the issue at hand:

    line 285 of eoi-shortcode.php (inside /includes/ folder):

    wp_localize_script( 'fca_eoi', 'fca_eoi', array( 'ajax_url' => admin_url( 'admin-ajax.php' ) ) );

    needs to be changed to:

    wp_localize_script( 'fca_eoi_script_js', 'fca_eoi', array( 'ajax_url' => admin_url( 'admin-ajax.php' ) ) );

    We will be deploying 1.5.1 to fix this within the next 24 hours.

    If you run into any other problems do let us know either here or support[at]fatcatapps[dot]com.

    Regards,
    Ryan

    yodathedark, how did you revert to the previous plugin version if you don’t mind me asking?

    Plugin Author Ryan Novotny

    (@ryannovotny)

    This page has the previous downloads if you wish to revert to 1.4.2:

    https://wordpress.org/plugins/campaign-monitor-wp/developers/

    Thanks Ryan but this line of code was already written that way.

    Plugin Author Ryan Novotny

    (@ryannovotny)

    Sorry, I just edited my post – line 285

    Thanks Ryan. This fixed the javascript error, however I’m noticing that the loading spinner next to the submit button seems to be constantly loading which is affecting the layout of the contact form? It was not doing this before the update.

    http://teamgat.com/

    @gramirez68, I had the advantage of having the website stored in a git repo so I just rolled-back the change.

    Plugin Author Ryan Novotny

    (@ryannovotny)

    @gramirez68 did you revert to 1.4.2? I just looked at your website but there is no spinner. The spinner shouldn’t affect the layout but this might be something I haven’t ran in to.

    Regards,
    Ryan

    I did revert to 1.4.2 for now. When I update to version 1.5.0 the spinner pushes the Submit button to the right which affects the alignment. The spinner itself is set to visibility: hidden in the CSS but the browser still treats it as part of the layout.

    Plugin Author fatcatapps

    (@fatcatapps)

    Hi,
    I’m sorry you’re having issues. We’ll try to get this fixed ASAP.

    Can you please send us an email at support[at]fatcatapps[dot]com referencing this ticket? Please include an admin login so we can debug properly. (Best to create a new temporary admin user for us.)

    Cheers!

    Plugin Author Ryan Novotny

    (@ryannovotny)

    @gramirez68 I’ve made some updates for 1.5.2 that change the spinner (significantly). It will now use the css “display: none” instead of “visibility: hidden” until the user clicks on the button. It should therefor not affect the layouts (though I haven’t been able to replicate your problem specifically).

    Thanks Ryan. I just updated and it looks good!

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘JS issues with 1.5.0’ is closed to new replies.