Support » Plugin: Breeze - WordPress Cache Plugin » JS Grouping broken

  • Hi there,

    It looks like there is an issue with JS grouping.
    I’m getting this error when enabled: “SyntaxError: Unexpected token ‘%'”

    When looking at the content of the generated JS file, I see indeed that it starts with a “%”.

    The generated JS file starts with this:

    %
    console.log('PixelYourSite PRO version 7.5.4');
    
                    window.pysWooSelectContentData = window.pysWooSelectContentData || [];
                
                            window.pysWooSelectContentData *REMOVED*
    
                                        ;
    
    			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mysite.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
    			/*! This file is auto-generated */

    That code seems to come from inline JS. However, “Include inline JS” is not ticked in Breeze settings!
    So that shouldn’t be included in the minified file anyway!

    If I enable “Include inline JS”, everything is working properly and there is no error.
    But I don’t want to include inline javascript into the minified file.

    Are you aware of this issue?

    PS: I’m using the latest Breeze version

    • This topic was modified 6 months, 1 week ago by t4k4.
Viewing 1 replies (of 1 total)
  • Plugin Author adeelkhan

    (@adeelkhan)

    Could you please confirm that did you add JS script through a plugin Or Manually?

Viewing 1 replies (of 1 total)
  • The topic ‘JS Grouping broken’ is closed to new replies.