Support » Plugin: Mastodon Autopost » Js files not found

  • Resolved lgnap

    (@lgnap)


    Hello,

    I see that plugin doesn’t work anymore.
    In addition to that on plugin’s settings page two js files are in 404.
    I checked also on the file system the following files are not there.

    I tried to uninstall and reinstall the plugin but doesn’t change anything.

    The following error log is relevant for the case:

    2018/01/06 18:09:59 [error] 1719#1719: *403146 open() "server-path-confidential/wp-content/plugins/autopost-to-mastodon/css/settingsPage.css" failed (2: No such file or directory), client: 127.0.0.1, server: lgnap.helpcomputer.org, request: "GET /wp-content/plugins/autopost-to-mastodon/css/settingsPage.css?ver=4.9.1 HTTP/1.1", host: "lgnap.helpcomputer.org", referrer: "https://lgnap.helpcomputer.org/wp-admin/options-general.php?page=mastodon-settings-page"
    2018/01/06 18:09:59 [error] 1719#1719: *403145 open() "server-path-confidential/wp-content/plugins/autopost-to-mastodon/js/testConnection.js" failed (2: No such file or directory), client: 127.0.0.1, server: lgnap.helpcomputer.org, request: "GET /wp-content/plugins/autopost-to-mastodon/js/testConnection.js?ver=4.9.1 HTTP/1.1", host: "lgnap.helpcomputer.org", referrer: "https://lgnap.helpcomputer.org/wp-admin/options-general.php?page=mastodon-settings-page"
    

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author l1am0

    (@l1am0)

    Hey Ignap,

    the new wordpress update broke some stuff with script loading.

    Should be fixed in version 2.0

    Indeed, this part is working 😉 thk.

    Still a bug with auth process however: maybe forgot something.

    I got when i wrote my mstdn domain (mstdn.io) and click on login:
    Client authentication failed due to unknown client, no client authentication included, or unsupported authentication method.

    I tried both with and without being logged in to mastodon before. Same result for the both. I use 2FA, maybe the source of problem.

    Plugin Author l1am0

    (@l1am0)

    Could you please provide me a screenshot of the error message on mstdn.io.

    Plugin Author l1am0

    (@l1am0)

    The authentication bug is fixed in version 2.0.0.2

    This sort of bugs will not happen again in the future.
    I started to test with different instances to prevent this stuff in the future.
    My bad that till now I only tested with mastodon.social.

    Sorry mate.

    BR,
    L1am0

    You work fast and well.
    Don’t apology for this 🙂

    This is working, thanks !

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Js files not found’ is closed to new replies.