Support » Plugin: The SEO Framework » JS error in WP 5.6

  • Resolved cjyabraham

    (@cjyabraham)


    I’ve just upgraded to WP 5.6 and I’m getting a new error on the post edit screen:

    Uncaught TypeError: Cannot read property 'querySelector' of null
    https://lfph.lndo.site/wp-content/plugins/autodescription/lib/js/post.js?ver=4.1.2 line 410

    Any ideas?

    Thanks,
    Chris

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter cjyabraham

    (@cjyabraham)

    I’m also getting this error:

    Uncaught TypeError: Cannot set property 'placeholder' of null
    https://lfph.lndo.site/wp-content/plugins/autodescription/lib/js/post.js?ver=4.1.2 line 818
    Plugin Author Sybre Waaijer

    (@cybr)

    Hi Chris,

    Thanks for the reports!

    Unfortunately, I am unable to reproduce the errors.

    The first error corresponds to the ‘noindex’ settings field, whereas the second error is related to the ‘social image URL’ input field.

    It seems that some TSF post-edit input-fields have been made unavailable/inaccessible via some means; is this correct?

    Thread Starter cjyabraham

    (@cjyabraham)

    Hi Sybre,
    Thanks for the quick response. To help you reproduce, I should say that these errors only occur on the edit screen for post types that have been excluded in the “Post Type Exclusions” setting. I’m seeing now that this was also a problem on previous versions of the plugin and WP, so sorry for the misleading subject line. Does that help?

    Chris

    Plugin Author Sybre Waaijer

    (@cybr)

    Hi Chris,

    Happy New Year!

    I understand why the issue is happening now: The persistent-notice cache probably wasn’t cleared properly on your site, instigating all script-loading, including those expecting certain HTML elements to be present.

    You can safely ignore the warnings, for the code wouldn’t(‘ve) lead to anything otherwise anyway. I’ve created an issue on GitHub about this: https://github.com/sybrew/the-seo-framework/issues/573.

    Thanks for your input, and sorry for the belated reply!

    Thread Starter cjyabraham

    (@cjyabraham)

    Thanks Sybre. And happy new year!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘JS error in WP 5.6’ is closed to new replies.