Support » Plugin: Slimstat Analytics » Js error

  • Resolved needmystyle

    (@needmystyle)


    I just updated to 4.6.2 and the plugin was working fine at 4.6.1 but now im getting a

    Uncaught ReferenceError: SlimStatParams is not defined at wp-slimstat.min.js:1.

    The plugin is registering incoming visitos fine just the main tracking graph isnt displaying anything. uniquie ip and visitors at 0. I tried the no panic button and cleared cache. Any help?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Jason Crouse

    (@coolmann)

    Please clear your browser/server cache, as we updated some code in the Javascript tracker. See if that helps. If it doesn’t, can you please post the URL of your site so that I can run some tests?

    Jason

    Thread Starter needmystyle

    (@needmystyle)

    Ok i will try that. In the meantime my website is needmystyle.com

    Thread Starter needmystyle

    (@needmystyle)

    no dice on the cache clear. 3 different computers

    Plugin Author Jason Crouse

    (@coolmann)

    I see you have some kind of source code minimizer on your site. Is that Autoptimize? That plugin needs some extra configuration so that it leaves our tracking code untouched. Please contact the developer for more information.

    Jason

    Thread Starter needmystyle

    (@needmystyle)

    I already have it set to ignore slimstat.admin.js and wp-slimstat.min.js. Am I missing one?

    Please contact the developer for more information.

    AO’s developer is here, but you’d be better placed to specify which slimstat JS should be excluded, no? šŸ™‚

    generic info on how to exclude (& other troubleshooting tips) can be found in the AO FAQ.

    Thread Starter needmystyle

    (@needmystyle)

    I added wp-slimstat.js. I dont know what else to exclude as I excluded all js files associated with slimstat. It was working fine on 4.6.1 without excluding. Is it possible to get back that version?

    Plugin Author Jason Crouse

    (@coolmann)

    You can always download previous version from:

    https://wordpress.org/plugins/wp-slimstat/developers/

    Make sure to NOT uninstall the plugin, or you will lose all the data. Just overwrite the files.

    Jason

    Plugin Author Jason Crouse

    (@coolmann)

    Thank you @futtta for always being on top of these issues šŸ™‚

    more then welcome @coolman šŸ™‚

    Thread Starter needmystyle

    (@needmystyle)

    This is for everyone, downgrading didn’t help but i got it to work by disabling:

    Check this option for Automatize to also aggregate JS in the HTML. If this option is not enabled, you might have to “force JavaScript in head”.

    Thanks

    Plugin Author Jason Crouse

    (@coolmann)

    Marking as resolved.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Js error’ is closed to new replies.