Support » Plugin: LiteSpeed Cache » JS combinne, get eror: “Uncaught type eror. Can not read property

  • Resolved thaikieutrinh2018

    (@thaikieutrinh2018)


    Hi Lscache.

    When I only active JS combine, this issue display.
    Screenshot: https://prnt.sc/yzkfuq
    Website to check: https://growth.vn (please use DevTool to check it)
    While wait your reply, I will turn on Js combine for you check
    Please help me how to fix it.

    I don’t want only because this issue, so don’t use “JS combine” feature. You know, JS combine make site faster very much

    Thanks for your help
    Thai T
    p/s: – I have disable all optimaze css, js, after turn on one-by-one to find this issue come from “JS combine”
    – I don’t know “JS exclude” what url to fix this

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Have you purged the cache after you changed settings?

    Thread Starter thaikieutrinh2018

    (@thaikieutrinh2018)

    Ofcourse, and purged lscache, cacche css/js, object..

    Check your requests in dev console -> network tab. There is a huge number of .js files that can’t be found and redirects for .js files.

    Thread Starter thaikieutrinh2018

    (@thaikieutrinh2018)

    Thanks for your quick reply,

    So, will I check that devtool-> network tab-> js, right?
    Should I check JS eror: before combine js, or after combine js?

    Neither nor, set default settings, purge cache and look if redirections and missing sources disappears. This is not a typical behaviour of cache plugin

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    so if you disable JS combine , it doesn’t have issue ?

    if that so , you probably need to exclude certain JS files from being combined

    please check this page

    Best regards,

    Thread Starter thaikieutrinh2018

    (@thaikieutrinh2018)

    The problem is I don’t know which JS file to exclude.
    Below are video screen capture errors, when I activce JS combine (of course, I have to say again: I always purge cache after each change)
    https://screencast-o-matic.com/watch/crnXjFSF0V
    Can you login to my website, with a temporary admin account, to check?

    Thread Starter thaikieutrinh2018

    (@thaikieutrinh2018)

    @qtwrk , can you help me?

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please try this way :

    if you enable JS combine , but disable “combine inline and external ” , purge all , does it work ?

    Best regards,

    Thread Starter thaikieutrinh2018

    (@thaikieutrinh2018)

    Yes, I have done like this, not work, still error

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    So please confirm ,

    JS combine -> ON

    combine inline and external JS -> OFF

    and issue still there.

    if above is true , then add

    wp-content
    wp-include

    into JS exclude list, purge all , see how it goes

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    I’m going to mark this topic “Resolved”, due to lack of activity.

    If you still need help, please feel free to re-open it.

    When re-open it, please also change the topic status to “not solved”

    Best regards,

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘JS combinne, get eror: “Uncaught type eror. Can not read property’ is closed to new replies.