WordPress.org

Support

Support » Plugins and Hacks » Hacks » jQuery x theme incompatibility?

jQuery x theme incompatibility?

  • breathelifein
    Participant

    @biellebrunner

    Not sure if I should be posting this here, or on the “Themes” forum, so I apologize if it’s the wrong place.

    I recently changed themes, and ever since then some things haven’t been working properly, like tabber tabs, a poll plugin, a chat plugin. They worked well with the other theme, but not with the new one. I did some searching, and it seems like it’s some sort of jQuery incompatibility, except the jQuery is up to date.

    Could anyone take a look at my site for me, and see if that’s really the case, or if it’s something else? – http://castlefanatic.com.br/
    If needed, my ccs: http://pastebin.com/AF7UibQY , header.php: http://pastebin.com/BTq4wAzw and functions.php: http://pastebin.com/XsMSfMSf
    Thanks.

Viewing 1 replies (of 1 total)
  • catacaustic
    very awesome

    @catacaustic

    The version of jQuery that’s used in WordPress was recently upgraded from 1.9 to 1.10, and that’s created a few issues for older JavaScript calls that relied in the functionality that was deprecated and then removed in 1.10.

    Unfortunately, the only ways to get around this is to either disable the JavaScript that the themes using, get the theme’s author to fix the errors, or fix the errors yourself if you’re 100% sure that the author isn’t going to do anything about it.

Viewing 1 replies (of 1 total)
  • The topic ‘jQuery x theme incompatibility?’ is closed to new replies.