WordPress.org

Forums

Squelch Tabs and Accordions Shortcodes
[resolved] jQuery UI Theme not Changing (4 posts)

  1. Victor Font
    Member
    Posted 1 year ago #

    This is a bit of a strange issue. When I attempt to change the jQquery UI theme under the Appearance menu, I have to save the changed theme twice before it holds. I can change the dropdown, save it and immediately the screen refreshes with the old theme displayed in the dropdown. If change it a second time and save it, the new theme saves, but it does absolutely nothing to change the style on the previewed page.

    I think the problem on the previewed page is due to the fact that I am adding the shortcodes to custom html to display a tabbed interface for a Formidable Pro form. I've turned off the Formidable Pro stylings, but the problem with the tab styles persists. The tab stylings work fine in a standard post. I'd like to get this solved, because I want to use your plugin for a tutorial I'm going to film demonstrating how to create a tabbed interface for Formidable Pro forms.

    https://wordpress.org/plugins/squelch-tabs-and-accordions-shortcodes/

  2. Victor Font
    Member
    Posted 1 year ago #

    I figured a few things out. The first issue seems to be limited to the dropdown display. The theme actually changes but the drop down doesn't update to reflect the change until the second save.

    The issue with Formidable Pro is due to the fact that Formidable Pro loads a version of jQuery UI to support its date object. If you turn off the jQuery load in Formidable Pro, your plugin takes over and even formats the Formidable date object correctly.

  3. Matt Lowe
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Victor,

    This is a known bug which has crept in somewhere in the last couple of versions. As you say, when you save the settings the theme IS updated, but the dropdown still shows the previous setting. If you exit the settings screen and go back the dropdown shows the new value.

    The issue with Formidable Pro is due to the fact that Formidable Pro loads a version of jQuery UI to support its date object. If you turn off the jQuery load in Formidable Pro, your plugin takes over and even formats the Formidable date object correctly.

    This is a common problem with plugins loading their own version of jQuery / jQuery UI. It's non-standard and breaks everyone else's plugins. I'll try and find time to take a look at the free version of Formidable Pro and implement a workaround to force Formidable to play nice with Squelch TAAS.

  4. Victor Font
    Member
    Posted 1 year ago #

    Hi Matt,

    Thanks for you response. The work around with Formidable Pro is easy. Navigate to Formidable/Global Settings/Form Styling. Scroll down to Calendar and set the jQuery UI to none. Your plugin takes over the styling and even formats the Formidable Pro calendar.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Squelch Tabs and Accordions Shortcodes
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.